aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-16 16:23:05 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-16 16:23:05 +0200
commite17ee503d9a4754bb8ee8b04f65d48404b731264 (patch)
tree235504886404e68cc705b9c530e72e9ebc65b8c2
parentsci-chemistry/shiftx: Bump to EAPI=5 and fix license (diff)
downloadsci-e17ee503d9a4754bb8ee8b04f65d48404b731264.tar.gz
sci-e17ee503d9a4754bb8ee8b04f65d48404b731264.tar.bz2
sci-e17ee503d9a4754bb8ee8b04f65d48404b731264.zip
broken ebuild for java fixing
Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-chemistry/shiftx2/metadata.xml28
-rw-r--r--sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild74
2 files changed, 102 insertions, 0 deletions
diff --git a/sci-chemistry/shiftx2/metadata.xml b/sci-chemistry/shiftx2/metadata.xml
new file mode 100644
index 000000000..8fb55f2b3
--- /dev/null
+++ b/sci-chemistry/shiftx2/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription>
+ SHIFTX2 predicts both the backbone and side chain 1H, 13C and 15N chemical
+ shifts for proteins using their structural (PDB) coordinates as input.
+ SHIFTX2 combines ensemble machine learning methods with sequence
+ alignment-based methods to calculate protein chemical shifts for backbone
+ and side chain atoms. SHIFTX2 has been trained on a carefully selected set of
+ 197 proteins and tested on a separate set of 61 proteins. Both the training
+ and testing sets consisted of high resolution X-ray structures (less 2.1A)
+ with carefully verified chemical shifts assignments. SHIFTX2 is able to attain
+ correlation coefficients between experimentally observed and predicted
+ backbone chemical shifts of 0.9800 (15N), 0.9959 (13CA), 0.9992 (13CB),
+ 0.9676 (13CO), 0.9714 (1HN), 0.9744 (1HA) and RMS errors of 1.1169, 0.4412,
+ 0.5163, 0.5330, 0.1711, and 0.1231 ppm, respectively. Comparisons to other
+ chemical shift predictors using the same testing data set indicates that
+ SHIFTX2 is substantially more accurate (up to 26% better by correlation
+ coefficient with an RMS error that is up to 3.3X smaller) than any other
+ program.
+
+ Please cite the following: Beomsoo Han, Yifeng Liu, Simon Ginzinger, and
+ David Wishart. (2011) SHIFTX2: significantly improved protein chemical shift
+ prediction. Journal of Biomolecular NMR, Volume 50, Number 1, 43-57.
+ doi: 10.1007/s10858-011-9478-4.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild b/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild
new file mode 100644
index 000000000..b13677b61
--- /dev/null
+++ b/sci-chemistry/shiftx2/shiftx2-1.07_p20120106.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit java-pkg-2 java-pkg-simple python-r1 versionator
+
+MY_PV="$(delete_all_version_separators $(get_version_component_range 1-2))"
+MY_PATCH="20120106"
+MY_P="${PN}-v${MY_PV}-linux"
+
+DESCRIPTION="Predicts both the backbone and side chain 1H, 13C and 15N chemical shifts for proteins"
+HOMEPAGE="http://shiftx2.wishartlab.com/"
+SRC_URI="http://shiftx2.wishartlab.com/download/${MY_P}-${MY_PATCH}.tgz"
+
+SLOT="0"
+LICENSE="all-rights-reserved"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND="dev-util/weka"
+
+RDEPEND="${CDEPEND}
+ dev-lang/R
+ >=virtual/jre-1.5"
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+ mkdir "${S}"/build || die
+ ejavac -classpath "$(java-pkg_getjars weka)" -nowarn -d "${S}"/build $(find src/ -name "*.java")
+ jar cf "${PN}.jar" -C "${S}"/build . || die
+ ejavac -cp $(java-pkg_getjars weka):. -Xlint ShiftXp.java
+
+
+ cd "${S}"/modules/angles || die
+ emake clean
+ emake CFLAGS="${CFLAGS}" GCC=$(tc-getCC) LINK="${LDFLAGS}" get_angles phipsi
+
+}
+
+src_install() {
+ java-pkg_dolauncher ${PN} --main "ShiftXp"
+
+
+ local instdir="/opt/${PN}"
+ dodoc README 1UBQ.pdb
+ python_parallel_foreach_impl python_doscript *py
+
+ # modules/angles
+ cd "${S}"/modules/angles || die
+ dobin get_angles phipsi
+
+
+ # script
+ python_scriptinto ${instdir}/script
+ python_parallel_foreach_impl python_doscript script/*py
+ exeinto ${instdir}/script
+ doexe script/*.r
+
+
+ # shifty3
+ insinto ${instdir}
+ doins -r shifty3
+ python_scriptinto ${instdir}/shifty3
+ python_parallel_foreach_impl python_doscript shifty3/*py
+ exeinto ${instdir}/shifty3
+ doexe shifty3/xalign_x
+}