aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2013-02-28 00:44:00 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2013-02-28 00:44:00 +0000
commite1e2e501e3d433e142027ef6bbb72e1d93892068 (patch)
tree0e82a6bc1d94cd73896a202208ee199a09e0dcfd
parentsci-libs/armadillo: Small prefix fix (diff)
downloadsci-e1e2e501e3d433e142027ef6bbb72e1d93892068.tar.gz
sci-e1e2e501e3d433e142027ef6bbb72e1d93892068.tar.bz2
sci-e1e2e501e3d433e142027ef6bbb72e1d93892068.zip
sci-libs/mlpack: Added a patch to respect libdir, and debug flag for profiling and debugging (thanks Ryan Curtin)
Package-Manager: portage-2.2.0_alpha163
-rw-r--r--sci-libs/mlpack/ChangeLog8
-rw-r--r--sci-libs/mlpack/files/mlpack-1.0.4-libdir.patch13
-rw-r--r--sci-libs/mlpack/mlpack-1.0.4-r1.ebuild (renamed from sci-libs/mlpack/mlpack-1.0.4.ebuild)11
3 files changed, 31 insertions, 1 deletions
diff --git a/sci-libs/mlpack/ChangeLog b/sci-libs/mlpack/ChangeLog
index faaa8c9a2..aae0b96f5 100644
--- a/sci-libs/mlpack/ChangeLog
+++ b/sci-libs/mlpack/ChangeLog
@@ -2,6 +2,14 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*mlpack-1.0.4-r1 (28 Feb 2013)
+
+ 28 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/mlpack-1.0.4-libdir.patch, +mlpack-1.0.4-r1.ebuild,
+ -mlpack-1.0.4.ebuild:
+ sci-libs/mlpack: Added a patch to respect libdir, and debug flag for profiling
+ and debugging (thanks Ryan Curtin)
+
*mlpack-1.0.4 (25 Feb 2013)
25 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
diff --git a/sci-libs/mlpack/files/mlpack-1.0.4-libdir.patch b/sci-libs/mlpack/files/mlpack-1.0.4-libdir.patch
new file mode 100644
index 000000000..c22c8110a
--- /dev/null
+++ b/sci-libs/mlpack/files/mlpack-1.0.4-libdir.patch
@@ -0,0 +1,13 @@
+--- mlpack-1.0.4/src/mlpack/CMakeLists.txt.old 2013-02-08 16:45:45.218117489 -0500
++++ mlpack-1.0.4/src/mlpack/CMakeLists.txt 2013-02-08 16:45:59.938263211 -0500
+@@ -62,8 +62,8 @@
+ # be entered...
+ install(TARGETS mlpack
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+ # For 'make test'.
+ add_custom_target(test
diff --git a/sci-libs/mlpack/mlpack-1.0.4.ebuild b/sci-libs/mlpack/mlpack-1.0.4-r1.ebuild
index 09bd23f76..21bbce84f 100644
--- a/sci-libs/mlpack/mlpack-1.0.4.ebuild
+++ b/sci-libs/mlpack/mlpack-1.0.4-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="http://www.mlpack.org/files/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
+IUSE="debug doc"
RDEPEND="
dev-libs/boost
@@ -26,11 +26,20 @@ DEPEND="${DEPEND}
DOCS=( HISTORY.txt )
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libdir.patch
sed -i \
-e "s:share/doc/mlpack:share/doc/${PF}:" \
CMakeLists.txt || die
}
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use debug DEBUG)
+ $(cmake-utils_use debug PROFILE)
+ )
+ cmake-utils_src_configure
+}
+
src_compile() {
cmake-utils_src_compile all $(use doc && echo doc)
}