aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-02-20 09:29:48 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-02-20 09:29:48 +0000
commite1e9eb52db867f77648f9ca053ab52457b2aa0f7 (patch)
treecb0fd2ca471382c285e6d6b9dab755f24a543418
parentscipy-0.4.6 version bump (diff)
downloadsci-e1e9eb52db867f77648f9ca053ab52457b2aa0f7.tar.gz
sci-e1e9eb52db867f77648f9ca053ab52457b2aa0f7.tar.bz2
sci-e1e9eb52db867f77648f9ca053ab52457b2aa0f7.zip
added numpy-0.9.5
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@109 32389bae-6d03-0410-99cf-db05cde120eb
-rw-r--r--dev-python/numpy/Manifest2
-rw-r--r--dev-python/numpy/files/digest-numpy-0.9.51
-rw-r--r--dev-python/numpy/numpy-0.9.5.ebuild32
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
new file mode 100644
index 000000000..c6bfc30f5
--- /dev/null
+++ b/dev-python/numpy/Manifest
@@ -0,0 +1,2 @@
+MD5 5238e63b838e1c26ed682d2c3050cea8 files/digest-numpy-0.9.5 63
+MD5 7c579039255ec74d905ddfeeeb9636dc numpy-0.9.5.ebuild 626
diff --git a/dev-python/numpy/files/digest-numpy-0.9.5 b/dev-python/numpy/files/digest-numpy-0.9.5
new file mode 100644
index 000000000..907083862
--- /dev/null
+++ b/dev-python/numpy/files/digest-numpy-0.9.5
@@ -0,0 +1 @@
+MD5 47fe186078c5e1f68b37e0ffc4994178 numpy-0.9.5.tar.gz 923172
diff --git a/dev-python/numpy/numpy-0.9.5.ebuild b/dev-python/numpy/numpy-0.9.5.ebuild
new file mode 100644
index 000000000..68e0f1223
--- /dev/null
+++ b/dev-python/numpy/numpy-0.9.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Numpy contains a powerful N-dimensional array object for Python."
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
+HOMEPAGE="http://numeric.scipy.org/"
+DEPEND=">=dev-lang/python-2.3
+ virtual/lapack
+ virtual/blas"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s: f77blas: blas:g" \
+ -e "s:'f77blas':'blas':g" \
+ numpy/distutils/system_info.py
+}
+
+src_install() {
+ distutils_src_install
+ dodoc numpy/doc/*
+}
+