aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2012-09-01 11:32:43 +0200
committerHonza Macháček <Hloupy.Honza@centrum.cz>2012-09-01 11:32:43 +0200
commite4450bb769287be345b4ab831aee1102f537286e (patch)
tree4895167557b0e6064b5ad1b2093da1ca79b0c003
parentunbundle netcdf from paraview (diff)
downloadsci-e4450bb769287be345b4ab831aee1102f537286e.tar.gz
sci-e4450bb769287be345b4ab831aee1102f537286e.tar.bz2
sci-e4450bb769287be345b4ab831aee1102f537286e.zip
Patches for sci-libs/bigdft to install GPU support corrected not to break linking against the compiled libraries
-rw-r--r--sci-libs/bigdft/ChangeLog11
-rw-r--r--sci-libs/bigdft/bigdft-1.6_pre1-r4.ebuild (renamed from sci-libs/bigdft/bigdft-1.6_pre1-r3.ebuild)4
-rw-r--r--sci-libs/bigdft/files/bigdft-1.6-tuto.1-GPUlibs-1.patch (renamed from sci-libs/bigdft/files/bigdft-1.6-tuto.1-GPUlibs.patch)21
-rw-r--r--sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc-1.patch (renamed from sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc.patch)8
4 files changed, 19 insertions, 25 deletions
diff --git a/sci-libs/bigdft/ChangeLog b/sci-libs/bigdft/ChangeLog
index dad986751..1f24f098c 100644
--- a/sci-libs/bigdft/ChangeLog
+++ b/sci-libs/bigdft/ChangeLog
@@ -4,6 +4,17 @@
<<<<<<< HEAD
+*bigdft-1.6_pre1-r4 (01 Sep 2012)
+
+ 01 Sep 2012; Honza Macháček <Hloupy.Honza@centrum.cz>
+ -bigdft-1.6_pre1-r3.ebuild, +bigdft-1.6_pre1-r4.ebuild,
+ -files/bigdft-1.6-tuto.1-GPUlibs.patch,
+ +files/bigdft-1.6-tuto.1-GPUlibs-1.patch,
+ -files/bigdft-1.6-tuto.1-bigdft.pc.patch,
+ +files/bigdft-1.6-tuto.1-bigdft.pc-1.patch:
+ Patches to install GPU support corrected not to break linking against the
+ compiled libraries
+
10 Jul 2012; Honza Macháček <Hloupy.Honza@centrum.cz>
files/bigdft-1.6-tuto.1-GPUlibs.patch:
bigdft-1.6-tuto.1-GPUlibs.patch updated not to forget the pkg-config file
diff --git a/sci-libs/bigdft/bigdft-1.6_pre1-r3.ebuild b/sci-libs/bigdft/bigdft-1.6_pre1-r4.ebuild
index a2cef02de..95bbebf41 100644
--- a/sci-libs/bigdft/bigdft-1.6_pre1-r3.ebuild
+++ b/sci-libs/bigdft/bigdft-1.6_pre1-r4.ebuild
@@ -64,9 +64,9 @@ pkg_setup() {
src_prepare() {
epatch \
"${FILESDIR}"/"${REAL_P}"-libxc_dir_include.patch \
- "${FILESDIR}"/"${REAL_P}"-bigdft.pc.patch \
+ "${FILESDIR}"/"${REAL_P}"-bigdft.pc-1.patch \
"${FILESDIR}"/"${REAL_P}"-gcc-4.6.patch \
- "${FILESDIR}"/"${REAL_P}"-GPUlibs.patch
+ "${FILESDIR}"/"${REAL_P}"-GPUlibs-1.patch
sed -i -e's/capitalize_module_ext/ax_fc_mod_ext/g' "${S}"/configure || die
sed -i -e's/capitalize_module_ext/ax_fc_mod_ext/g' "${S}"/configure.ac || die
eautoreconf
diff --git a/sci-libs/bigdft/files/bigdft-1.6-tuto.1-GPUlibs.patch b/sci-libs/bigdft/files/bigdft-1.6-tuto.1-GPUlibs-1.patch
index 507966518..386e39dc7 100644
--- a/sci-libs/bigdft/files/bigdft-1.6-tuto.1-GPUlibs.patch
+++ b/sci-libs/bigdft/files/bigdft-1.6-tuto.1-GPUlibs-1.patch
@@ -1,24 +1,3 @@
-diff -Naur orig/bigdft-1.6-tuto.1.orig/configure.ac patched/bigdft-1.6-tuto.1/configure.ac
---- bigdft-1.6-tuto.1.orig/configure.ac 2012-07-10 08:50:27.000000000 +0000
-+++ bigdft-1.6-tuto.1/configure.ac 2012-07-10 09:03:46.303491671 +0000
-@@ -295,7 +295,7 @@ if test x"$ac_use_cuda_gpu" = "xyes" ; t
- fi
- fi
- AC_SUBST(NVCC_FLAGS)
-- LIBCUDA_LIBS="-L$ac_cuda_lib_path -lcudart -lcublas"
-+ LIBCUDA_LIBS="-L$ac_cuda_lib_path -lGPU -lcudart -lcublas"
- fi
-
- dnl Use the OpenCL support
-@@ -332,7 +332,7 @@ if test x"$ac_use_ocl" = "xyes" ; then
- ac_use_ocl="no"
- else
- dnl LIBOCL_LIBS="-L$ac_ocl_path/lib -lOpenCL -lm -lrt -lstdc++"
-- LIBOCL_LIBS="-L$ac_ocl_path/lib -lOpenCL -lm"
-+ LIBOCL_LIBS="-L$ac_ocl_path/lib -lOCL -lOpenCL -lm"
- fi
- LIBS=$LIBS_OLD
- fi
diff -Naur orig/bigdft-1.6-tuto.1.orig/src/CUDA/Makefile.am patched/bigdft-1.6-tuto.1/src/CUDA/Makefile.am
--- bigdft-1.6-tuto.1.orig/src/CUDA/Makefile.am 2011-09-27 12:43:06.000000000 +0000
+++ bigdft-1.6-tuto.1/src/CUDA/Makefile.am 2012-07-04 12:08:27.000000000 +0000
diff --git a/sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc.patch b/sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc-1.patch
index 3ddde7014..7c3380a9b 100644
--- a/sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc.patch
+++ b/sci-libs/bigdft/files/bigdft-1.6-tuto.1-bigdft.pc-1.patch
@@ -158,7 +158,11 @@ diff -Naur bigdft-1.6-tuto_orig/Makefile.in bigdft-1.6-tuto/Makefile.in
diff -Naur bigdft-1.6-tuto_orig/bigdft.pc.in bigdft-1.6-tuto/bigdft.pc.in
--- bigdft.pc.in 1970-01-01 00:00:00.000000000 +0000
+++ bigdft.pc.in 2012-02-01 09:43:59.000000000 +0000
-@@ -0,0 +1,11 @@
+@@ -0,0 +1,15 @@
++@USE_CUDA_GPU_FALSE@libs_cuda=
++@USE_CUDA_GPU_TRUE@libs_cuda=$(top_builddir)/src/CUDA/libGPU.a
++@USE_OCL_FALSE@libs_ocl=
++@USE_OCL_TRUE@libs_ocl=$(top_builddir)/src/OpenCL/libOCL.a -lstdc++
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
@@ -168,7 +172,7 @@ diff -Naur bigdft-1.6-tuto_orig/bigdft.pc.in bigdft-1.6-tuto/bigdft.pc.in
+Description: Library for DFT calculation over wavelets.
+Requires:
+Version: @VERSION@
-+Libs: -L${libdir} -lbigdft -lpoissonsolver @LIBS@ @FCLIBS@
++Libs: -L${libdir} -lbigdft -lpoissonsolver ${libs_cuda} ${libs_ocl} @LIBS@ @FCLIBS@
+Cflags: -I${includedir}
diff -Naur bigdft-1.6-tuto_orig/configure bigdft-1.6-tuto/configure
--- configure 2012-03-21 10:03:26.000000000 +0000