aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-02-20 23:31:41 +0100
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-02-20 23:31:41 +0100
commite64b4a5e9631f6e0ed1f0b281190f435ecfbc5f0 (patch)
tree5454a84308ca7c5d866080d9b906f5618d4992c7
parentImosflm checked in but masked because deps are missing or tbw (diff)
parenttktreectrl: dep for new ccp4, from bug #217706. (diff)
downloadsci-e64b4a5e9631f6e0ed1f0b281190f435ecfbc5f0.tar.gz
sci-e64b4a5e9631f6e0ed1f0b281190f435ecfbc5f0.tar.bz2
sci-e64b4a5e9631f6e0ed1f0b281190f435ecfbc5f0.zip
Merged dev-tcltk/tktreectrl into sci overlay
-rw-r--r--dev-tcltk/tktreectrl/ChangeLog0
-rw-r--r--dev-tcltk/tktreectrl/Manifest4
-rw-r--r--dev-tcltk/tktreectrl/metadata.xml8
-rw-r--r--dev-tcltk/tktreectrl/tktreectrl-2.2.5.ebuild31
-rw-r--r--licenses/tktreectrl38
5 files changed, 81 insertions, 0 deletions
diff --git a/dev-tcltk/tktreectrl/ChangeLog b/dev-tcltk/tktreectrl/ChangeLog
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/dev-tcltk/tktreectrl/ChangeLog
diff --git a/dev-tcltk/tktreectrl/Manifest b/dev-tcltk/tktreectrl/Manifest
new file mode 100644
index 000000000..d549f5d6e
--- /dev/null
+++ b/dev-tcltk/tktreectrl/Manifest
@@ -0,0 +1,4 @@
+DIST tktreectrl-2.2.5.tar.gz 707312 RMD160 3439022cb4afd2c7ad6f2aa397e5b4d6d4433134 SHA1 4403aa8a371927cf3b22c34246fe5d5d46f02702 SHA256 6c43ffdcb1c76b05efb2255bc84e99da82b72559c398d9c1b2540995deb02875
+EBUILD tktreectrl-2.2.5.ebuild 717 RMD160 253031e775dec394b1ba8584d755ccfe268d4e0c SHA1 8eee682a6245ac06aa1823c757744e3e54810ea9 SHA256 01cf8a041112ebdb4368a13327581a86ade6d41909303703e5f4547fd636b947
+MISC ChangeLog 0 RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 SHA1 da39a3ee5e6b4b0d3255bfef95601890afd80709 SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
+MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
diff --git a/dev-tcltk/tktreectrl/metadata.xml b/dev-tcltk/tktreectrl/metadata.xml
new file mode 100644
index 000000000..efb490d78
--- /dev/null
+++ b/dev-tcltk/tktreectrl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-tcltk/tktreectrl/tktreectrl-2.2.5.ebuild b/dev-tcltk/tktreectrl/tktreectrl-2.2.5.ebuild
new file mode 100644
index 000000000..b6024259d
--- /dev/null
+++ b/dev-tcltk/tktreectrl/tktreectrl-2.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A flexible listbox widget for Tk"
+HOMEPAGE="http://tktreectrl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="tktreectrl"
+SLOT="0"
+IUSE="X threads debug"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="mirror"
+DEPEND=">=dev-lang/tcl-8.4"
+
+src_compile() {
+ econf \
+ $(use_enable threads) \
+ $(use_enable amd64 64bit) \
+ $(use_enable debug symbols) \
+ $(use_enable X x) \
+ --enable-shared
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog README.txt
+ mv "${D}"/usr/lib/treectrl${PV}/htmldoc "${D}"/usr/share/doc/${P}/
+}
diff --git a/licenses/tktreectrl b/licenses/tktreectrl
new file mode 100644
index 000000000..f08986dc8
--- /dev/null
+++ b/licenses/tktreectrl
@@ -0,0 +1,38 @@
+This software is copyrighted by Tim Baker and other parties. The
+following terms apply to all files associated with the software unless
+explicitly disclaimed in individual files.
+
+The authors hereby grant permission to use, copy, modify, distribute,
+and license this software and its documentation for any purpose, provided
+that existing copyright notices are retained in all copies and that this
+notice is included verbatim in any distributions. No written agreement,
+license, or royalty fee is required for any of the authorized uses.
+Modifications to this software may be copyrighted by their authors
+and need not follow the licensing terms described here, provided that
+the new terms are clearly indicated on the first page of each file where
+they apply.
+
+IN NO EVENT SHALL THE AUTHORS OR DISTRIBUTORS BE LIABLE TO ANY PARTY
+FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES
+ARISING OUT OF THE USE OF THIS SOFTWARE, ITS DOCUMENTATION, OR ANY
+DERIVATIVES THEREOF, EVEN IF THE AUTHORS HAVE BEEN ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
+
+THE AUTHORS AND DISTRIBUTORS SPECIFICALLY DISCLAIM ANY WARRANTIES,
+INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT. THIS SOFTWARE
+IS PROVIDED ON AN "AS IS" BASIS, AND THE AUTHORS AND DISTRIBUTORS HAVE
+NO OBLIGATION TO PROVIDE MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR
+MODIFICATIONS.
+
+GOVERNMENT USE: If you are acquiring this software on behalf of the
+U.S. government, the Government shall have only "Restricted Rights"
+in the software and related documentation as defined in the Federal
+Acquisition Regulations (FARs) in Clause 52.227.19 (c) (2). If you
+are acquiring the software on behalf of the Department of Defense, the
+software shall be classified as "Commercial Computer Software" and the
+Government shall have only "Restricted Rights" as defined in Clause
+252.227-7013 (c) (1) of DFARs. Notwithstanding the foregoing, the
+authors grant the U.S. Government and others acting in its behalf
+permission to use and distribute the software in accordance with the
+terms specified in this license.