aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-04-25 10:48:42 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-04-25 10:48:42 +0200
commite6e7792e71292e2fe9e6276b6fb638401e2e5905 (patch)
tree3eec6befe757e018d5d378e4108438f1a67f26e1
parentsci-libs/clfft: Drop old (diff)
downloadsci-e6e7792e71292e2fe9e6276b6fb638401e2e5905.tar.gz
sci-e6e7792e71292e2fe9e6276b6fb638401e2e5905.tar.bz2
sci-e6e7792e71292e2fe9e6276b6fb638401e2e5905.zip
sci-libs/clblas: Drop old
Package-Manager: portage-2.2.26
-rw-r--r--sci-libs/clblas/Manifest1
-rw-r--r--sci-libs/clblas/clblas-2.6-r1.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/sci-libs/clblas/Manifest b/sci-libs/clblas/Manifest
index bc8bce486..7e53bdf84 100644
--- a/sci-libs/clblas/Manifest
+++ b/sci-libs/clblas/Manifest
@@ -1,3 +1,2 @@
DIST clblas-2.10.tar.gz 1154117 SHA256 72a46cb92f6057d10b503ce23d62db73d7332eb0645bb8bca3337f4c0558b429 SHA512 5ed43104aae565292e0df4cc9e014cf483ccc0ff89257ebb5817f6508bfc9593585ed658da639f2167fbfb5d92ef116be4d5de3694f56e1a1e228bd42b1c05c6 WHIRLPOOL 1a96142dc0e7aad076d1e61508b943da8ac176bd889cac89a3cab1aab64a1d8a6bc207bda4483be7dc726af600b660370548ee06db4d28d4b6643b7bff9419e8
-DIST clblas-2.6.tar.gz 954586 SHA256 4607561a648949709bc7c368be4aaf7346174406e678454b643e31cfe861830c SHA512 76756707c8a217b926dff4c288ce48700e21a80650e14b25f81615b25bb81c47e328900e94712ba9bcd5690f29647b4782157df85623cfe1c696f3698fcd62d6 WHIRLPOOL e1a8f596a187216b69a339919601dec978ad43728f9a5965454139d53391a2ac25314d6be28eef52cfdff43551d72f07b0bf6145a931d643731f5969b7f13379
DIST clblas-2.8.tar.gz 1144713 SHA256 66dd8454443e3257015f71f4bb13e614c5c27bea121eab4100dd851ac4641ce8 SHA512 866b02b995f6c717e954cea0d05dcbbde13906e0f9fbdcf81373a1317a4b61bb6565afb45271f943f99e5742155e9a1d2b5224e469f757a7c02d6adb5b43055a WHIRLPOOL 5131f5529b169b25335a08b053b23400956b63d02d41cf8d062469fd18f62f2ec58871dbef4cb5b3b3870b342c5aab89157e4e8a796c1cd47ec9c0c7055c9b2f
diff --git a/sci-libs/clblas/clblas-2.6-r1.ebuild b/sci-libs/clblas/clblas-2.6-r1.ebuild
deleted file mode 100644
index 15ca8d534..000000000
--- a/sci-libs/clblas/clblas-2.6-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-single-r1
-
-MY_PN="clBLAS"
-
-DESCRIPTION="A software library containing BLAS routines for OpenCL"
-HOMEPAGE="https://github.com/clMathLibraries/clBLAS"
-SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+client examples +ktest performance test"
-
-REQUIRED_USE="performance? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/boost
- virtual/opencl
- || ( >=dev-util/amdapp-2.9 dev-util/intel-ocl-sdk )
- performance? ( ${PYTHON_DEPS} )
- "
-DEPEND="${RDEPEND}"
-# test? (
-# >=dev-cpp/gtest-1.6.0
-# >=sci-libs/acml-6.1.0.3
-# )"
-
-# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
-# Therefore src_test() won't execute any test.
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_PN}-${PV}/src"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
- die "Compilation with gcc older than 4.6 is not supported."
- fi
- fi
-
- if [ ! -d "/usr/local/include/CL" ]; then
- eerror "As a temporary workaround for Bug #521734, a symlink pointing to"
- eerror "OpenCL headers >= 1.2 is needed. A symlink pointing to the CL-1.2"
- eerror "headers, provided by the eselect-opencl package, can be created with"
- eerror ""
- eerror " ln -s /usr/lib64/OpenCL/global/include/CL-1.2/ /usr/local/include/CL"
- eerror ""
- die "/usr/local/include/CL not found"
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_build client CLIENT)
- $(cmake-utils_use_build examples SAMPLE)
- $(cmake-utils_use_build ktest KTEST)
- $(cmake-utils_use_build performance PERFORMANCE)
- $(cmake-utils_use_build test TEST)
- -DOPENCL_ROOT="/usr/local/include"
- )
- cmake-utils_src_configure
-}