aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-02-19 17:31:43 +0000
committerJustin Lecher <jlec@gentoo.org>2017-02-19 17:53:03 +0000
commite8b0fd48193d3c44f958c9695e7cc4f08310048e (patch)
tree0f14814a6abe5af1726da63cc6145c954d13286d
parentdev-cpp/icnc: Bump to EAPI=6 (diff)
downloadsci-e8b0fd48193d3c44f958c9695e7cc4f08310048e.tar.gz
sci-e8b0fd48193d3c44f958c9695e7cc4f08310048e.tar.bz2
sci-e8b0fd48193d3c44f958c9695e7cc4f08310048e.zip
sys-cluster/blcr: Bump to EAPI=6
drop old Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sys-cluster/blcr/Manifest1
-rw-r--r--sys-cluster/blcr/blcr-0.8.4.ebuild58
-rw-r--r--sys-cluster/blcr/blcr-0.8.5.ebuild8
3 files changed, 4 insertions, 63 deletions
diff --git a/sys-cluster/blcr/Manifest b/sys-cluster/blcr/Manifest
index eec239834..d061aef59 100644
--- a/sys-cluster/blcr/Manifest
+++ b/sys-cluster/blcr/Manifest
@@ -1,2 +1 @@
-DIST blcr-0.8.4.tar.gz 905080 SHA256 d851da66627d9212ac37bc9ea2aba40008ff2dc51d45dbd395ca2e403c3d78cf SHA512 828e950ca5f5e1d88428c009f710e9ebdae7292e298b2a6c59bcc74a919382427226f9fec7312ed81618b70e96509ca7815ec4a833a6a6922d8ecdcff3821e97 WHIRLPOOL 4a42fddfffd226551008dd200a24b57db3b30cd117e58cb7bd22479f21f7d713cdedcc05a2bb572d1caee955dcf6d5667b2903062f1f66206d9a4fba5942d064
DIST blcr-0.8.5.tar.gz 921596 SHA256 60c969b3870c793c3f4af7241a0418b5a97e4bd954d316ed2de1e4e56c024805 SHA512 9089b9f04d948f6a470dd54026167ca8a4330b51f0ee74a2dd98b5cf17d9090950b82f66727a7d09da746a450b061c0ac9991e21de23dd596180be469c28d795 WHIRLPOOL 0f7e3b6b86fe1f305786d597f75319be7e918ed554a3484a7cc427fa085c62efb71d76301c9bb38f24fdf27077e0995c9c02a10f2a266b51236ede2ff931d156
diff --git a/sys-cluster/blcr/blcr-0.8.4.ebuild b/sys-cluster/blcr/blcr-0.8.4.ebuild
deleted file mode 100644
index 5fbfc13cd..000000000
--- a/sys-cluster/blcr/blcr-0.8.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit linux-mod
-
-DESCRIPTION="Berkeley Lab Checkpoint/Restart for Linux"
-HOMEPAGE="https://ftg.lbl.gov/projects/CheckpointRestart"
-SRC_URI="https://crd.lbl.gov/assets/Uploads/FTG/Projects/CheckpointRestart/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-# up to kernel 2.6.38
-
-pkg_setup() {
- local msg
- linux-info_pkg_setup
-
- # kernel version check
- if kernel_is gt 2 6 38; then
- eerror "${PN} is being developed and tested up to linux-2.6.38."
- eerror "Make sure you have a proper kernel version and point"
- eerror " /usr/src/linux symlink or env variable KERNEL_DIR to it!"
- die "Wrong kernel version ${KV_FULL}"
- fi
-
- linux-mod_pkg_setup
- MODULE_NAMES="blcr(blcr::${S}/cr_module/kbuild)
- blcr_imports(blcr::${S}/blcr_imports/kbuild)"
- BUILD_TARGETS="clean all"
- ECONF_PARAMS="--with-kernel=${KV_DIR}"
-}
-
-src_install() {
- dodoc README NEWS
- cd "${S}"/util || die
- default
- cd "${S}"/libcr || die
- default
- cd "${S}"/man || die
- default
- cd "${S}"/include || die
- default
- linux-mod_src_install
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- einfo "Be sure to add blcr to your modules.autoload.d to"
- einfo "ensure that the modules get loaded on your next boot"
-}
diff --git a/sys-cluster/blcr/blcr-0.8.5.ebuild b/sys-cluster/blcr/blcr-0.8.5.ebuild
index 4a4046c3e..21bb2c33f 100644
--- a/sys-cluster/blcr/blcr-0.8.5.ebuild
+++ b/sys-cluster/blcr/blcr-0.8.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit linux-mod
@@ -15,8 +15,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-MAKEOPTS="${MAKEOPTS} -j1"
-
# up to kernel 2.6.38
pkg_setup() {
@@ -37,6 +35,8 @@ pkg_setup() {
blcr_imports(blcr::${S}/blcr_imports/kbuild)"
BUILD_TARGETS="clean all"
ECONF_PARAMS="--with-kernel=${KV_DIR}"
+
+ MAKEOPTS+=" -j1"
}
src_install() {