aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-09-29 03:37:59 -0400
committerHorea Christian <chr@chymera.eu>2020-09-29 03:37:59 -0400
commitece68587d232f21cc40130c56a76aeb6e44b85a1 (patch)
treeebbc210ccb7f34a1aa5c5cfe44a7d91d4cf32030
parentsci-mathematics/dolfin: removed package with missing dep (diff)
downloadsci-ece68587d232f21cc40130c56a76aeb6e44b85a1.tar.gz
sci-ece68587d232f21cc40130c56a76aeb6e44b85a1.tar.bz2
sci-ece68587d232f21cc40130c56a76aeb6e44b85a1.zip
sys-cluster/htcondor: updated dependency list
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--sys-cluster/htcondor/Manifest2
-rw-r--r--sys-cluster/htcondor/htcondor-8.0.0.ebuild13
-rw-r--r--sys-cluster/htcondor/htcondor-8.3.2.ebuild8
3 files changed, 13 insertions, 10 deletions
diff --git a/sys-cluster/htcondor/Manifest b/sys-cluster/htcondor/Manifest
index 44889bcaa..3b4613c56 100644
--- a/sys-cluster/htcondor/Manifest
+++ b/sys-cluster/htcondor/Manifest
@@ -1,2 +1,2 @@
-DIST condor_src-8.0.0-all-all.tar.gz 18636227 SHA256 b1fe7cedcab17d713a64b57dbb2a5f0426979316b8f309f9492ff60f7b43d3a8 SHA512 a335d0cb200f1899711f6f87968a01a2f5dcd37fede2ef973f2863a3f628d6f04421abbaaa22a310711ea1367af3a4f68e31c5e91e8cee1149cc5957d6ac0119 WHIRLPOOL 4c755644cd2ba5f7414ac3c8374df141b98d3e830f07a0ea0e0cc46b575ac8b42c1e47135cb9a87342bd41309b03df1693de1836cd250ea7e6ace1c3445ebd25
+DIST htcondor-8.0.0.tar.gz 17972558 BLAKE2B 16dd196c15eb3aec8bd358c19443d10ad1c6765a89e12a71f009916ef9c1d1e3eb995480b3ce80d17521e46529a535a7b0d8819bf15fc396b6c8106e0735a7c5 SHA512 ae4ce04a0beaf051c8055e893b29c5257db6233b8ae9f7575d70debefb12306453589195a9e4cd602feacdb30d9ba3f59700881976412e4e417a597e33dbd456
DIST htcondor-8.3.2.tar.gz 18451391 BLAKE2B ab30e6bb2bfbcd67e1f4e03e10ec7b52fb7b5c707bb7451c97327032c1be663db145b378113bcd1f46cb6dc4edd32298afba0bb554504368db3b4c92a669a98b SHA512 588d2dd4586be6d135a658cc54b01ed2c02a1127495af68c73f69d33df98bdafe7e1fc248950e4af3ca14fc1bd6329f003a61daf875580646eddabe6201b353c
diff --git a/sys-cluster/htcondor/htcondor-8.0.0.ebuild b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
index 5e25f0325..bc2cde521 100644
--- a/sys-cluster/htcondor/htcondor-8.0.0.ebuild
+++ b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CMAKE_MIN_VERSION=2.8
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6..9} )
inherit cmake-utils python-single-r1 user
DESCRIPTION="Workload management system for compute-intensive jobs"
HOMEPAGE="http://www.cs.wisc.edu/htcondor/"
-SRC_URI="condor_src-${PV}-all-all.tar.gz"
+SRC_URI="https://github.com/${PN}/${PN}/archive/V${PV//./_}.tar.gz -> ${P}.tar.gz"
+#SRC_URI="condor_src-${PV}-all-all.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -23,7 +24,9 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
CDEPEND="
sys-libs/zlib
>=dev-libs/libpcre-7.6
- >=dev-libs/boost-1.49.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/boost[${PYTHON_USEDEP}]
+ ')
net-nds/openldap
boinc? ( sci-misc/boinc )
cgroup? ( >=dev-libs/libcgroup-0.37 )
@@ -43,8 +46,6 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
mail-client/mailx"
-RESTRICT=fetch
-
S="${WORKDIR}/condor-${PV}"
PATCHES=(
"${FILESDIR}"/condor_shadow_dlopen-${PV}.patch
diff --git a/sys-cluster/htcondor/htcondor-8.3.2.ebuild b/sys-cluster/htcondor/htcondor-8.3.2.ebuild
index c4464b88f..f15bda520 100644
--- a/sys-cluster/htcondor/htcondor-8.3.2.ebuild
+++ b/sys-cluster/htcondor/htcondor-8.3.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CMAKE_MIN_VERSION=2.8
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6..9} )
inherit cmake-utils python-single-r1 user vcs-snapshot
@@ -22,7 +22,9 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
CDEPEND="sys-libs/zlib
>=dev-libs/libpcre-7.6
- >=dev-libs/boost-1.49.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/boost[${PYTHON_USEDEP}]
+ ')
net-nds/openldap
boinc? ( sci-misc/boinc )
cgroup? ( >=dev-libs/libcgroup-0.37 )