aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2014-10-15 01:16:44 -0400
committerJustin Bronder <jsbronder@gentoo.org>2014-10-15 01:20:53 -0400
commitf3f2fb58009c4563d6c432e25ed2010b006d9662 (patch)
treeef83a081c806c1cb4816467138bbccdccfa1be60
parentfix p4est dependency; drop old (diff)
downloadsci-f3f2fb58009c4563d6c432e25ed2010b006d9662.tar.gz
sci-f3f2fb58009c4563d6c432e25ed2010b006d9662.tar.bz2
sci-f3f2fb58009c4563d6c432e25ed2010b006d9662.zip
sys-cluster/openmpi: bump
-rw-r--r--sys-cluster/openmpi/ChangeLog5
-rw-r--r--sys-cluster/openmpi/Manifest1
-rw-r--r--sys-cluster/openmpi/openmpi-1.8.3.ebuild167
3 files changed, 173 insertions, 0 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 80e0ae9f1..c64028650 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*openmpi-1.8.3 (15 Oct 2014)
+
+ 15 Oct 2014; Justin Bronder <jsbronder@gentoo.org> +openmpi-1.8.3.ebuild:
+ sys-cluster/openmpi: bump
+
*openmpi-1.8.1 (03 Jun 2014)
03 Jun 2014; Justin Bronder <jsbronder@gentoo.org> +openmpi-1.8.1.ebuild:
diff --git a/sys-cluster/openmpi/Manifest b/sys-cluster/openmpi/Manifest
index 6b62b65f9..12992eb5f 100644
--- a/sys-cluster/openmpi/Manifest
+++ b/sys-cluster/openmpi/Manifest
@@ -1,3 +1,4 @@
DIST openmpi-1.6.5.tar.bz2 10943881 SHA256 fe37bab89b5ef234e0ac82dc798282c2ab08900bf564a1ec27239d3f1ad1fc85 SHA512 b0ede0264cd9263b8ba59ec51d17ad47b5f20d49d219ca05f7c396d608398d517b2023a46a2535fd6191160d709e4805c4de436dcfee56eda287383bd69f9652 WHIRLPOOL d0288677827c1deba17295ee1b69cd21da294ac314cc49404389b4c286384f9f2f229cae4c4fd62511e7f20abc510998642d6a2edfac3f16f83078f474f8e735
DIST openmpi-1.7.3.tar.bz2 12479769 SHA256 438d96c178dbf5a1bc92fa1d238a8225d87b64af26ce2a07789faaf312117e45 SHA512 a66d3b1df2a7dc76df4ffa0083919cefb0e7d4133f80bfd5c1c4bf6c5254f2a4773e3c4c9069c39b1467057c406eba3ea892d4a86030b0bd8097d12073af8ef8 WHIRLPOOL 5509f48370f5a00fee68048df5d84824fa63e528df617fc9209840f3077c2c868dbf2c3da964334e7a80c428056a5e2f9a39ddcda9967350e68222444ca918f0
DIST openmpi-1.8.1.tar.bz2 13297716 SHA256 171427ebc007943265f33265ec32e15e786763952e2bfa2eac95e3e192c1e18f SHA512 f1b35ace5c62c89dccdab3f2ee774dae8eaf7d7bd9e41136bb5953f9c61207620917d1905be95350215c6dbc03b494ddd18732b6b7520893e51c5b1a8861fb99 WHIRLPOOL 4d429e7c23131f050aebad11f6eb9048b09979af58d1efbbdc5f6d1d349bd5164745fdbc2ec53f326d8ae99b9af2313e2bc2bf1fb675343e8e231b787ff0aa4d
+DIST openmpi-1.8.3.tar.bz2 13301056 SHA256 2ef02dab61febeb74714ff80d508c00b05defc635b391ed2c8dcc1791fbc88b3 SHA512 dbb8ae576d5272defdf5fd9cc09ddcd488d9076e2f4f6b1bc1a49e7ce6345784e1a637615705873feead7c86b20c3ec204cddda8fdbab58342e76f07752154dc WHIRLPOOL 98ef14928e1f620d89212ae53c2353fc96e801a3da96997bd09572e411e7debd30d49b846af459bfe92f7b79e3efadfe74ed4668a85d82ef0324cfaf4e07ed80
diff --git a/sys-cluster/openmpi/openmpi-1.8.3.ebuild b/sys-cluster/openmpi/openmpi-1.8.3.ebuild
new file mode 100644
index 000000000..73db0009f
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-1.8.3.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit cuda eutils flag-o-matic fortran-2 multilib mpi toolchain-funcs versionator
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+IUSE_OPENMPI_FABRICS="
+ openmpi_fabrics_ofed
+ openmpi_fabrics_knem
+ openmpi_fabrics_open-mx
+ openmpi_fabrics_psm"
+
+IUSE_OPENMPI_RM="
+ openmpi_rm_pbs
+ openmpi_rm_slurm"
+
+IUSE_OPENMPI_OFED_FEATURES="
+ openmpi_ofed_features_control-hdr-padding
+ openmpi_ofed_features_connectx-xrc
+ openmpi_ofed_features_udcm
+ openmpi_ofed_features_rdmacm
+ openmpi_ofed_features_dynamic-sl
+ openmpi_ofed_features_failover"
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="http://www.open-mpi.org"
+SRC_URI="http://www.open-mpi.org/software/ompi/v$(get_version_component_range 1-2)/downloads/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="cma cuda +cxx elibc_FreeBSD fortran heterogeneous ipv6 mpi-threads romio threads vt
+ ${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
+
+REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
+ openmpi_rm_pbs? ( !openmpi_rm_slurm )
+ openmpi_fabrics_psm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_control-hdr-padding? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_connectx-xrc? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_udcm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_rdmacm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_dynamic-sl? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_failover? ( openmpi_fabrics_ofed )"
+
+MPI_UNCLASSED_DEP_STR="
+ vt? (
+ !dev-libs/libotf
+ !app-text/lcdf-typetools
+ )"
+
+RDEPEND="
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ dev-libs/libevent
+ >=sys-apps/hwloc-1.7.2
+ sys-libs/zlib
+ elibc_FreeBSD? ( dev-libs/libexecinfo )
+ openmpi_fabrics_ofed? ( sys-infiniband/ofed )
+ openmpi_fabrics_knem? ( sys-cluster/knem )
+ openmpi_fabrics_open-mx? ( sys-cluster/open-mx )
+ openmpi_fabrics_psm? ( sys-infiniband/infinipath-psm )
+ openmpi_rm_pbs? ( sys-cluster/torque )
+ openmpi_rm_slurm? ( sys-cluster/slurm )
+ openmpi_ofed_features_rdmacm? ( sys-infiniband/librdmacm )
+ $(mpi_imp_deplist)"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ fortran-2_pkg_setup
+ MPI_ESELECT_FILE="eselect.mpi.openmpi"
+
+ if use mpi-threads; then
+ echo
+ ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
+ ewarn "default and officially unsupported by upstream."
+ ewarn "You may stop now and set USE=-mpi-threads"
+ echo
+ fi
+
+ echo
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ echo
+}
+
+src_prepare() {
+ # Necessary for scalibility, see
+ # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
+ if use threads; then
+ echo 'oob_tcp_listen_mode = listen_thread' \
+ >> opal/etc/openmpi-mca-params.conf
+ fi
+}
+
+src_configure() {
+ local myconf=(
+ --sysconfdir="${EPREFIX}/etc/${PN}"
+ --enable-pretty-print-stacktrace
+ --enable-orterun-prefix-by-default
+ --with-hwloc="${EPREFIX}/usr"
+ )
+
+ if use mpi-threads; then
+ myconf+=(--enable-mpi-threads
+ --enable-opal-multi-threads)
+ fi
+
+ if use fortran; then
+ if [[ $(tc-getFC) =~ g77 ]]; then
+ myconf+=(--disable-mpi-f90)
+ elif [[ $(tc-getFC) =~ if ]]; then
+ # Enabled here as gfortran compile times are huge with this enabled.
+ myconf+=(--with-mpi-f90-size=medium)
+ fi
+ else
+ myconf+=(--disable-mpi-f90 --disable-mpi-f77)
+ fi
+
+ ! use vt && myconf+=(--enable-contrib-no-build=vt)
+
+ econf $(mpi_econf_args) "${myconf[@]}" \
+ $(use_enable cxx mpi-cxx) \
+ $(use_with cma) \
+ $(use_with cuda cuda "${EPREFIX}"/opt/cuda) \
+ $(use_enable romio io-romio) \
+ $(use_enable heterogeneous) \
+ $(use_enable ipv6) \
+ $(use_with openmpi_fabrics_ofed verbs "${EPREFIX}"/usr) \
+ $(use_with openmpi_fabrics_knem knem "${EPREFIX}"/usr) \
+ $(use_with openmpi_fabrics_open-mx mx "${EPREFIX}"/usr) \
+ $(use_with openmpi_fabrics_psm psm "${EPREFIX}"/usr) \
+ $(use_enable openmpi_ofed_features_control-hdr-padding openib-control-hdr-padding) \
+ $(use_enable openmpi_ofed_features_connectx-xrc openib-connectx-xrc) \
+ $(use_enable openmpi_ofed_features_rdmacm openib-rdmacm) \
+ $(use_enable openmpi_ofed_features_udcm openib-udcm) \
+ $(use_enable openmpi_ofed_features_dynamic-sl openib-dynamic-sl) \
+ $(use_enable openmpi_ofed_features_failover btl-openib-failover) \
+ $(use_with openmpi_rm_pbs tm) \
+ $(use_with openmpi_rm_slurm slurm)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ # From USE=vt see #359917
+ rm "${ED}"/$(mpi_root)/usr/share/libtool &> /dev/null
+
+ # Avoid collisions with libevent
+ rm -rf "${ED}"/$(mpi_root)/usr/include/event2 &> /dev/null
+
+ # Remove la files, no static libs are installed and we have pkg-config
+ find "${ED}"/$(mpi_root)/usr/$(get_libdir)/ -type f -name '*.la' -delete
+
+ mpi_dodoc README AUTHORS NEWS VERSION || die
+ mpi_imp_add_eselect
+}
+
+src_test() {
+ # Doesn't work with the default src_test as the dry run (-n) fails.
+ emake -j1 check
+}