aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <sfabbro@uvic.ca>2012-07-27 15:07:55 -0700
committerSebastien Fabbro <sfabbro@uvic.ca>2012-07-27 15:07:55 -0700
commitf86c6651bf45231ea31273bd5e7419b326c4e770 (patch)
tree59ae795dc5eb1a22976f99005ce4368ad71ae263
parentsci-astronomy/zpeg: Initial import (diff)
downloadsci-f86c6651bf45231ea31273bd5e7419b326c4e770.tar.gz
sci-f86c6651bf45231ea31273bd5e7419b326c4e770.tar.bz2
sci-f86c6651bf45231ea31273bd5e7419b326c4e770.zip
sci-libs/atlas: added a generic flag for more generic architectures, and possibility for user to pass configure options via standard EXTRA_ECONF flags
(Portage version: 2.2.01.20796-prefix/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--sci-libs/atlas/ChangeLog6
-rw-r--r--sci-libs/atlas/atlas-3.10.0.ebuild25
-rw-r--r--sci-libs/atlas/files/atlas-3.10.0-x32-support.patch (renamed from sci-libs/atlas/files/atlas-3.10-x32-support.patch)0
-rw-r--r--sci-libs/atlas/metadata.xml4
4 files changed, 27 insertions, 8 deletions
diff --git a/sci-libs/atlas/ChangeLog b/sci-libs/atlas/ChangeLog
index edd02dbd7..22ed8b7a1 100644
--- a/sci-libs/atlas/ChangeLog
+++ b/sci-libs/atlas/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 27 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/atlas-3.10.0-x32-support.patch, -files/atlas-3.10-x32-support.patch,
+ atlas-3.10.0.ebuild, metadata.xml:
+ sci-libs/atlas: added a generic flag for more generic architectures, and
+ possibility for user to pass configure options via standard EXTRA_ECONF flags
+
16 Jul 2012; Olivier Huber <oli.huber@gmail.com>
+files/atlas-3.10-x32-support.patch, -files/3.9.76-x32.patch,
atlas-3.10.0.ebuild:
diff --git a/sci-libs/atlas/atlas-3.10.0.ebuild b/sci-libs/atlas/atlas-3.10.0.ebuild
index ea605c39e..e4f80bcd7 100644
--- a/sci-libs/atlas/atlas-3.10.0.ebuild
+++ b/sci-libs/atlas/atlas-3.10.0.ebuild
@@ -14,8 +14,8 @@ SRC_URI="mirror://sourceforge/math-atlas/${PN}${PV}.tar.bz2
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux"
-IUSE="fortran doc lapack static-libs threads"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="fortran doc generic lapack static-libs threads"
RDEPEND="fortran? ( virtual/fortran )"
DEPEND="${RDEPEND}
@@ -34,7 +34,7 @@ pkg_setup() {
ewarn "Run cpufreq-set -r -g performance as root"
die "${PN} needs all cpu set to performance"
fi
- cpu=$(( cpu + 1 ))
+ cpu=$((cpu + 1))
done
else
ewarn "Please make sure to disable CPU throttling completely"
@@ -47,7 +47,7 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/atlas-3.10-x32-support.patch
+ epatch "${FILESDIR}"/${P}-x32-support.patch
}
src_configure() {
@@ -69,7 +69,11 @@ src_configure() {
# OpenMP shown to decreased performance over POSIX threads
# (at least in 3.9.x, see atlas-dev mailing list)
if use threads; then
- myconf+=( "-t -1" "-Si omp 0" )
+ if use generic; then # 2 threads is most generic
+ myconf+=( "-t 2" "-Si omp 0" )
+ else
+ myconf+=( "-t -1" "-Si omp 0" )
+ fi
else
myconf+=( "-t 0" "-Si omp 0" )
fi
@@ -107,6 +111,11 @@ src_configure() {
else
myconf+=( "-Si latune 0" "--nof77" )
fi
+ # generic stuff found by make make xprint_enums in atlas build dir
+ # basically assuming sse2+sse1 and 2 threads max
+ use generic && use x86 && myconf+=( "-V 384 -A 13")
+ use generic && use amd64 && myconf+=( "-V 384 -A 24")
+
local confdir="${S}_${1}"; shift
myconf+=( $@ )
mkdir "${confdir}" && cd "${confdir}"
@@ -115,8 +124,8 @@ src_configure() {
"${S}"/configure ${myconf[@]} || die "configure in ${confdir} failed"
}
- atlas_configure shared "-Fa alg -fPIC"
- use static-libs && atlas_configure static
+ atlas_configure shared "-Fa alg -fPIC" ${EXTRA_ECONF}
+ use static-libs && atlas_configure static ${EXTRA_ECONF}
}
src_compile() {
@@ -267,5 +276,5 @@ src_install() {
dodoc INDEX.txt AtlasCredits.txt ChangeLog
use doc && dodoc atlas*pdf cblas.pdf cblasqref.pdf
use doc && use fortran && dodoc f77blas*pdf
- use doc && use fortran && use lapack && dodoc lapack*pdf
+ use doc && use fortran && use lapack && dodoc *lapack*pdf
}
diff --git a/sci-libs/atlas/files/atlas-3.10-x32-support.patch b/sci-libs/atlas/files/atlas-3.10.0-x32-support.patch
index 82e698069..82e698069 100644
--- a/sci-libs/atlas/files/atlas-3.10-x32-support.patch
+++ b/sci-libs/atlas/files/atlas-3.10.0-x32-support.patch
diff --git a/sci-libs/atlas/metadata.xml b/sci-libs/atlas/metadata.xml
index 94634e439..4aeff0d55 100644
--- a/sci-libs/atlas/metadata.xml
+++ b/sci-libs/atlas/metadata.xml
@@ -10,4 +10,8 @@
a subset of the linear algebra routine LAPACK library or the full
LAPACK using the reference LAPACK from Netlib.
</longdescription>
+<use>
+<flag name='generic'>Build atlas assuming a fairly generic
+architecture (sse2 for x86, core2 for amd64)</flag>
+</use>
</pkgmetadata>