aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-03-15 13:29:55 +0400
committerAlexey Shvetsov <alexxy@gentoo.org>2013-03-15 13:29:55 +0400
commitfa1afc31593c42a91ff3cbc04edbadf77c3568b6 (patch)
tree7ee6f9784825530f448037864d63e1415106866e
parentDrop Werror hack (diff)
downloadsci-fa1afc31593c42a91ff3cbc04edbadf77c3568b6.tar.gz
sci-fa1afc31593c42a91ff3cbc04edbadf77c3568b6.tar.bz2
sci-fa1afc31593c42a91ff3cbc04edbadf77c3568b6.zip
Fix build with cuda enabled
Package-Manager: portage-2.2.0_alpha166
-rw-r--r--sci-chemistry/gromacs/ChangeLog4
-rw-r--r--sci-chemistry/gromacs/gromacs-4.6.9999.ebuild2
2 files changed, 5 insertions, 1 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index bc0c78402..f9bd96e3b 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 15 Mar 2013; Alexey Shvetsov <alexxy@gentoo.org> gromacs-4.6.9999.ebuild,
+ gromacs-9999.ebuild:
+ Fix build with cuda enabled
+
10 Mar 2013; Christoph Junghans <ottxor@gentoo.org> gromacs-4.6.9999.ebuild:
added cuda build fix from gx86
diff --git a/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild b/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
index ca1499734..552ffcadc 100644
--- a/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.6.9999.ebuild
@@ -182,7 +182,7 @@ src_configure() {
local p
[[ ${x} = "double" ]] && p="-DGMX_DOUBLE=ON" || p="-DGMX_DOUBLE=OFF"
local cuda=( "-DGMX_GPU=OFF" )
- [[ ${x} = "single" ]] && use cuda && \
+ [[ ${x} = "float" ]] && use cuda && \
cuda=( -DGMX_GPU=ON -DCUDA_HOST_COMPILER_OPTIONS="${NVCCFLAGS}" )
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_MPI=OFF
$(cmake-utils_use threads GMX_THREAD_MPI) "${cuda[@]}" -DGMX_OPENMM=OFF