aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-22 20:47:01 +0200
committerJustin Lecher <jlec@gentoo.org>2012-05-22 20:47:01 +0200
commitfe9af8f2b9e1099e6b84ba7009fe7fdfaf6c110d (patch)
treefbf11438fe8b2010ca6e8a8d6b8b63f41640755b
parentdev-java/jogl: Add missing eutils.eclass, bump to EAPI=4, remove unnecessary ... (diff)
downloadsci-fe9af8f2b9e1099e6b84ba7009fe7fdfaf6c110d.tar.gz
sci-fe9af8f2b9e1099e6b84ba7009fe7fdfaf6c110d.tar.bz2
sci-fe9af8f2b9e1099e6b84ba7009fe7fdfaf6c110d.zip
dev-perl/Bio-BigFile: Add missing eutils.eclass, bump to EAPI=4, remove unnecessary bits
(Portage version: 2.2.0_alpha107/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-perl/Bio-BigFile/Bio-BigFile-1.06.ebuild11
-rw-r--r--dev-perl/Bio-BigFile/ChangeLog3
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-perl/Bio-BigFile/Bio-BigFile-1.06.ebuild b/dev-perl/Bio-BigFile/Bio-BigFile-1.06.ebuild
index f23ca23e9..7da661606 100644
--- a/dev-perl/Bio-BigFile/Bio-BigFile-1.06.ebuild
+++ b/dev-perl/Bio-BigFile/Bio-BigFile-1.06.ebuild
@@ -2,10 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=4
MODULE_AUTHOR="LDS"
-inherit perl-module
+
+inherit eutils flag-o-matic perl-module
DESCRIPTION="BigWig and BigBed file perl-based interface for Gbrowse-2"
@@ -21,7 +22,7 @@ DEPEND="${RDEPEND}
SRC_TEST="do"
src_prepare(){
- epatch "${FILESDIR}"/Build.PL.patch || die "Failed to patch Build.PL"
+ append-cflags -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing
+ append-lfs-flags
+ epatch "${FILESDIR}"/Build.PL.patch
}
-
-CFLAGS="${CFLAGS} -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
diff --git a/dev-perl/Bio-BigFile/ChangeLog b/dev-perl/Bio-BigFile/ChangeLog
index 7541c3f75..d899200ff 100644
--- a/dev-perl/Bio-BigFile/ChangeLog
+++ b/dev-perl/Bio-BigFile/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 22 May 2012; Justin Lecher <jlec@gentoo.org> Bio-BigFile-1.06.ebuild:
+ Add missing eutils.eclass, bump to EAPI=4, remove unnecessary bits
+
09 Feb 2012; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
Bio-BigFile-1.06.ebuild:
initial ebuild, see bug #402835