aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gmail.com>2013-10-14 15:01:56 -0600
committerNicolas Bock <nicolasbock@gmail.com>2013-10-14 15:01:56 -0600
commitfed7e0eef82681cf59c3fae1f96f53a749f88bc4 (patch)
treed437de619004a47779bdca56f5dd51213829acda
parentsci-chemistry/freeon-1.0.6: Version bump. (diff)
downloadsci-fed7e0eef82681cf59c3fae1f96f53a749f88bc4.tar.gz
sci-fed7e0eef82681cf59c3fae1f96f53a749f88bc4.tar.bz2
sci-fed7e0eef82681cf59c3fae1f96f53a749f88bc4.zip
sci-chemistry/namd-2.9: A little cleanup in ebuild.
Package-Manager: portage-2.2.1
-rw-r--r--sci-chemistry/namd/ChangeLog3
-rw-r--r--sci-chemistry/namd/namd-2.9.ebuild14
2 files changed, 10 insertions, 7 deletions
diff --git a/sci-chemistry/namd/ChangeLog b/sci-chemistry/namd/ChangeLog
index 0d712d03b..17b6a1489 100644
--- a/sci-chemistry/namd/ChangeLog
+++ b/sci-chemistry/namd/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Oct 2013; Nicolas Bock <nicolasbock@gmail.com> namd-2.9.ebuild:
+ sci-chemistry/namd-2.9: Some cleanup in ebuild.
+
02 Oct 2013; Nicolas Bock <nicolasbock@gmail.com> namd-2.9.ebuild:
sci-chemistry/namd-2.9: Fixed ebuild The build needs charm using static-libs.
diff --git a/sci-chemistry/namd/namd-2.9.ebuild b/sci-chemistry/namd/namd-2.9.ebuild
index daff52ce9..ce64615bc 100644
--- a/sci-chemistry/namd/namd-2.9.ebuild
+++ b/sci-chemistry/namd/namd-2.9.ebuild
@@ -11,9 +11,8 @@ LICENSE="namd"
HOMEPAGE="http://www.ks.uiuc.edu/Research/namd/"
MY_PN="NAMD"
-MY_PV="2.9"
-SRC_URI="${MY_PN}_${MY_PV}_Source.tar.gz"
+SRC_URI="${MY_PN}_${PV}_Source.tar.gz"
SLOT="0"
KEYWORDS="~amd64"
@@ -23,7 +22,7 @@ RESTRICT="fetch"
DEPEND="
app-shells/tcsh
- sys-cluster/charm[static-libs]
+ sys-cluster/charm
sci-libs/fftw:2.1
dev-lang/tcl"
@@ -33,15 +32,15 @@ NAMD_ARCH="Linux-x86_64-g++"
NAMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=NAMD"
-S="${WORKDIR}/${MY_PN}_${MY_PV}_Source"
+S="${WORKDIR}/${MY_PN}_${PV}_Source"
pkg_nofetch() {
echo
- einfo "Please download ${MY_PN}_${MY_PV}_Source.tar.gz from"
+ einfo "Please download ${MY_PN}_${PV}_Source.tar.gz from"
einfo "${NAMD_DOWNLOAD}"
einfo "after agreeing to the license and then move it to"
einfo "${DISTDIR}"
- einfo "Be sure to select the ${MY_PV} version!"
+ einfo "Be sure to select the ${PV} version!"
echo
}
@@ -56,6 +55,7 @@ src_prepare() {
-e "s:charm-.\+:charm-${CHARM_VERSION}:" \
-i Make.charm || die
+ # Remove charm distribution. We don't need it.
rm -f charm-6.4.0.tar || die
# proper compiler and cflags
@@ -76,7 +76,7 @@ src_prepare() {
src_configure() {
# configure
- ./config ${NAMD_ARCH} || die
+ ./config ${NAMD_ARCH} --charm-arch . || die
}
src_compile() {