aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-06-09 21:15:55 +0100
committerJustin Lecher <jlec@gentoo.org>2018-06-09 21:16:29 +0100
commit00006028fbf84a8e6b0022926a673b5be972c369 (patch)
tree2b4a668ed53607559962b17d09d877e89c8ca492 /app-admin/eselect/eselect-1.4.12-r100.ebuild
parentsci-biology/trimmomatic: version bump (diff)
downloadsci-00006028fbf84a8e6b0022926a673b5be972c369.tar.gz
sci-00006028fbf84a8e6b0022926a673b5be972c369.tar.bz2
sci-00006028fbf84a8e6b0022926a673b5be972c369.zip
app-admin/eselect: Version Bump
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.40, Repoman-2.3.9 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-admin/eselect/eselect-1.4.12-r100.ebuild')
-rw-r--r--app-admin/eselect/eselect-1.4.12-r100.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/app-admin/eselect/eselect-1.4.12-r100.ebuild b/app-admin/eselect/eselect-1.4.12-r100.ebuild
deleted file mode 100644
index 602a3c8e8..000000000
--- a/app-admin/eselect/eselect-1.4.12-r100.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils bash-completion-r1
-
-DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
-SRC_URI="https://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"
-
-LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-3.0 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc emacs vim-syntax"
-
-RDEPEND="
- !app-eselect/eselect-blas
- !app-eselect/eselect-lapack
- || (
- sys-apps/coreutils
- sys-freebsd/freebsd-bin
- app-misc/realpath
- )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- doc? ( dev-python/docutils )"
-RDEPEND="!app-admin/eselect-news
- ${RDEPEND}
- sys-apps/file
- sys-libs/ncurses"
-
-PDEPEND="emacs? ( app-emacs/eselect-mode )
- vim-syntax? ( app-vim/eselect-syntax )"
-
-PATCHES=( "${FILESDIR}"/${P}-alternatives.patch )
-
-src_prepare() {
- default
- AT_M4DIR="." eautoreconf
-}
-
-src_compile() {
- default
- use doc && emake html
-}
-
-src_install() {
- default
- newbashcomp misc/${PN}.bashcomp ${PN}
- dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
- use doc && dohtml *.html doc/*
-
- # needed by news module
- keepdir /var/lib/gentoo/news
- if use prefix; then
- sed -i \
- "s:ALTERNATIVESDIR_ROOTLESS=\"${EPREFIX}:ALTERNATIVESDIR_ROOTLESS=\":" \
- "${ED}"/usr/share/eselect/libs/alternatives-common.bash || die
- else
- fowners root:portage /var/lib/gentoo/news
- fperms g+w /var/lib/gentoo/news
- fi
-}
-
-pkg_postinst() {
- # fowners in src_install doesn't work for the portage group:
- # merging changes the group back to root
- if ! use prefix; then
- chgrp portage "${EROOT}/var/lib/gentoo/news" \
- && chmod g+w "${EROOT}/var/lib/gentoo/news"
- fi
-}