aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Arteaga <andyspiros@gmail.com>2012-08-28 18:03:36 +0200
committerAndrea Arteaga <andyspiros@gmail.com>2012-08-28 18:03:36 +0200
commit4afd5e65c0809c907d03e115c79e372bb5776846 (patch)
tree8dd9b6e9eecc40b9cb35a2e519143ab05438d2fb /app-benchmarks/numbench/numbench-0.2.ebuild
parentparaview 3.14.1 initial import to greater masses (diff)
downloadsci-4afd5e65c0809c907d03e115c79e372bb5776846.tar.gz
sci-4afd5e65c0809c907d03e115c79e372bb5776846.tar.bz2
sci-4afd5e65c0809c907d03e115c79e372bb5776846.zip
[app-benchmarks/numbench] Version bump.
Diffstat (limited to 'app-benchmarks/numbench/numbench-0.2.ebuild')
-rw-r--r--app-benchmarks/numbench/numbench-0.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-benchmarks/numbench/numbench-0.2.ebuild b/app-benchmarks/numbench/numbench-0.2.ebuild
new file mode 100644
index 000000000..4cb74f6bf
--- /dev/null
+++ b/app-benchmarks/numbench/numbench-0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit eutils distutils
+
+DESCRIPTION="Automated benchmarks suite"
+HOMEPAGE="http://soc.dev.gentoo.org/~spiros"
+SRC_URI="http://github.com/andyspiros/numbench/tarball/${PV} -> ${P}.tar.gz"
+CID="127a61c"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="!app-admin/eselect-blas
+ !app-admin/eselect-cblas
+ !app-admin/eselect-lapack
+ >=dev-python/matplotlib-1.0.0
+ =app-admin/eselect-1.3.1-r1"
+
+S="${WORKDIR}/andyspiros-numbench-${CID}"
+
+src_install() {
+ distutils_src_install
+
+ chmod +x exec.py
+ newbin exec.py numbench
+
+ insinto /usr/share/numbench/samples
+ doins samples/*.xml
+
+ doman doc/numbench.1
+}