aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2011-11-06 20:23:04 +0400
committerAndrew Savchenko <bircoph@gmail.com>2011-11-06 20:23:04 +0400
commitbdbceb4ec34ed6da14f0a4df78a42450400453da (patch)
tree4cf9401b10fd3ddb75868bb9271bf5b01e30b276 /app-doc/lapack-docs/lapack-docs-3.3-r1.ebuild
parentinitial commit (diff)
downloadsci-bdbceb4ec34ed6da14f0a4df78a42450400453da.tar.gz
sci-bdbceb4ec34ed6da14f0a4df78a42450400453da.tar.bz2
sci-bdbceb4ec34ed6da14f0a4df78a42450400453da.zip
lapack-docs: fix file clash with blas-docs
Do not install files belonging to blas-docs. This should fix bug 387981.
Diffstat (limited to 'app-doc/lapack-docs/lapack-docs-3.3-r1.ebuild')
-rw-r--r--app-doc/lapack-docs/lapack-docs-3.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-doc/lapack-docs/lapack-docs-3.3-r1.ebuild b/app-doc/lapack-docs/lapack-docs-3.3-r1.ebuild
new file mode 100644
index 000000000..6b43bc4e7
--- /dev/null
+++ b/app-doc/lapack-docs/lapack-docs-3.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Documentation reference and man pages for LAPACK implementations"
+HOMEPAGE="http://www.netlib.org/lapack/"
+SRC_URI="http://dev.gentoo.org/~bicatali/lapack-man-${PV}.tar.gz
+ http://www.netlib.org/lapack/lapackqref.ps"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 s390 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/manpages"
+
+src_install() {
+ # These belong to the blas-docs
+ rm -f man/manl/{csrot,lsame,xerbla,xerbla_array,zdrot}.*
+
+ # rename because doman do not yet understand manl files
+ # Not all systems have the rename command, like say FreeBSD
+ local f t
+ for f in man/manl/*.l; do
+ t="${f%%.l}.n"
+ mv "${f}" "${t}"
+ done
+ doman man/manl/*
+ dodoc README "${DISTDIR}"/lapackqref.ps
+}