aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-22 11:49:03 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-22 11:49:03 +0100
commitfb6d3bdb8b350200f25783f60cfb7e4c917c9359 (patch)
treefc301effc1ab31422106b8d6c66c3f1d108cef7a /app-forensics/vine/vine-1.0.ebuild
parentapp-doc/lapack-docs: Bump to EAPI=6 (diff)
downloadsci-fb6d3bdb8b350200f25783f60cfb7e4c917c9359.tar.gz
sci-fb6d3bdb8b350200f25783f60cfb7e4c917c9359.tar.bz2
sci-fb6d3bdb8b350200f25783f60cfb7e4c917c9359.zip
app-forensics/vine: Bump to EAPI=6
* Amend patches for -p1 * Use PATCHES=() Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-forensics/vine/vine-1.0.ebuild')
-rw-r--r--app-forensics/vine/vine-1.0.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/app-forensics/vine/vine-1.0.ebuild b/app-forensics/vine/vine-1.0.ebuild
index 683f9c964..3ee578265 100644
--- a/app-forensics/vine/vine-1.0.ebuild
+++ b/app-forensics/vine/vine-1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils toolchain-funcs
@@ -26,14 +26,13 @@ RDEPEND="${DEPEND}"
MAKEOPTS="${MAKEOPTS} -j1"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-binutils.patch \
- "${FILESDIR}"/${P}-gcc46.patch \
- "${FILESDIR}"/${P}-install.patch \
- "${FILESDIR}"/${P}-ocamlgraph182.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-binutils.patch
+ "${FILESDIR}"/${P}-gcc46.patch
+ "${FILESDIR}"/${P}-install.patch
+ "${FILESDIR}"/${P}-ocamlgraph182.patch
+)
src_compile() {
- emake CC=$(tc-getCC) CCFLAGS="${CFLAGS} -fpic"
+ emake CC=$(tc-getCC) CCFLAGS="${CFLAGS} -fPIC"
}