aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2009-01-15 15:54:30 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2009-01-15 15:54:30 +0000
commit55f67e638184001af38cdc0b6119cd00b1a9de64 (patch)
tree574265dc83c45c31788f8322c88a7388ddbbe0f6 /app-office/ekee/ekee-2.0.2.ebuild
parentUpdate mpi.eclass. Major changes include simplyfing use and allowing non emp... (diff)
downloadsci-55f67e638184001af38cdc0b6119cd00b1a9de64.tar.gz
sci-55f67e638184001af38cdc0b6119cd00b1a9de64.tar.bz2
sci-55f67e638184001af38cdc0b6119cd00b1a9de64.zip
Added ekee
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1368 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'app-office/ekee/ekee-2.0.2.ebuild')
-rw-r--r--app-office/ekee/ekee-2.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-office/ekee/ekee-2.0.2.ebuild b/app-office/ekee/ekee-2.0.2.ebuild
new file mode 100644
index 000000000..8d1b50009
--- /dev/null
+++ b/app-office/ekee/ekee-2.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils ruby
+
+DESCRIPTION="LaTeX equation editor"
+HOMEPAGE="http://rlehy.free.fr/"
+SRC_URI="http://rlehy.free.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-ruby/qt4-qtruby
+ virtual/latex-base
+ app-text/dvipng
+ media-gfx/pstoedit
+ media-gfx/imagemagick
+ x11-misc/xdg-utils"
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install-bin || die "emake install failed"
+ # install-doc is simple and not what we want
+ pod2man doc/ekee.pod ekee.1
+ doman ekee.1
+ dodoc changelog AUTHORS README TODO copyright
+ make_deskop_entry ekee Ekee
+}