aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-17 14:52:37 +0200
committerJustin Lecher <jlec@gentoo.org>2010-06-17 14:52:37 +0200
commita0a7f90224e419ab8bc68ff51331ab17bafce130 (patch)
treef1316c75605418027bb84b5e5219fd7302a822d6 /dev-cpp/growler-link/growler-link-0.3.7.ebuild
parentInCvs as sci-libs/punc (diff)
downloadsci-a0a7f90224e419ab8bc68ff51331ab17bafce130.tar.gz
sci-a0a7f90224e419ab8bc68ff51331ab17bafce130.tar.bz2
sci-a0a7f90224e419ab8bc68ff51331ab17bafce130.zip
Fix for compilation with gcc4.4, #271017
(Portage version: 2.2_rc67/git/Linux x86_64) (Signed Manifest commit)
Diffstat (limited to 'dev-cpp/growler-link/growler-link-0.3.7.ebuild')
-rw-r--r--dev-cpp/growler-link/growler-link-0.3.7.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/dev-cpp/growler-link/growler-link-0.3.7.ebuild b/dev-cpp/growler-link/growler-link-0.3.7.ebuild
index 260f182b4..c6c1bf3d0 100644
--- a/dev-cpp/growler-link/growler-link-0.3.7.ebuild
+++ b/dev-cpp/growler-link/growler-link-0.3.7.ebuild
@@ -1,37 +1,39 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-SLOT="0"
-LICENSE="NOSA"
+EAPI="3"
-KEYWORDS="~amd64 ~x86"
+inherit eutils
DESCRIPTION="Growler-Link: the lowest-level Growler library."
HOMEPAGE="http://www.nas.nasa.gov/~bgreen/growler/"
SRC_URI="${HOMEPAGE}/downloads/growler-link-${PV}.tar.gz"
+SLOT="0"
+LICENSE="NOSA"
+KEYWORDS="~amd64 ~x86"
IUSE="doc tcpd static fortran"
RDEPEND=">=dev-libs/boost-1.33.1
tcpd? ( sys-apps/tcp-wrappers )"
-
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gcc4.patch
+}
+
+src_configure() {
econf \
$(use_enable doc) \
$(use_enable tcpd) \
$(use_enable static) \
- $(use_enable fortran) \
- --enable-fast-install \
- || die "could not configure"
- emake || die "emake failed"
+ $(use_enable fortran)
}
src_install() {
emake DESTDIR="${D}" install || die "install failed"
- dodoc README NEWS AUTHORS NOSA ChangeLog
+ dodoc README NEWS AUTHORS NOSA ChangeLog || die
}