aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-09-25 13:20:25 -0600
committerChristoph Junghans <ottxor@gentoo.org>2014-09-25 13:20:25 -0600
commit8c2fcbd5dc12445c58b1a1d597396e9c7b5b1c6c (patch)
tree8c70cbdace84b4367813a30272d3f458983a1cc2 /dev-cpp/icnc/icnc-9999.ebuild
parentAdd xblas to the .pc file when it is in use see bug#523388 (diff)
downloadsci-8c2fcbd5dc12445c58b1a1d597396e9c7b5b1c6c.tar.gz
sci-8c2fcbd5dc12445c58b1a1d597396e9c7b5b1c6c.tar.bz2
sci-8c2fcbd5dc12445c58b1a1d597396e9c7b5b1c6c.zip
live ebuild update
Package-Manager: portage-2.2.8-r1
Diffstat (limited to 'dev-cpp/icnc/icnc-9999.ebuild')
-rw-r--r--dev-cpp/icnc/icnc-9999.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-cpp/icnc/icnc-9999.ebuild b/dev-cpp/icnc/icnc-9999.ebuild
index 8ab3b22d6..aeee540a9 100644
--- a/dev-cpp/icnc/icnc-9999.ebuild
+++ b/dev-cpp/icnc/icnc-9999.ebuild
@@ -12,13 +12,15 @@ HOMEPAGE="https://software.intel.com/en-us/articles/intel-concurrent-collections
if [[ $PV = 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/icnc/icnc.git"
+ KEYWORDS=
else
- SRC_URI="mirror://sourceforge/${PN}/${PV}/l_cnc_b_${PV}.tgz"
+ #SRC_URI="mirror://sourceforge/${PN}/${PV}/l_cnc_b_${PV}.tgz"
+ SRC_URI="https://github.com/martine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64"
IUSE=""
DEPEND="
@@ -29,13 +31,9 @@ RDEPEND="${DEPEND}"
src_configure() {
#TODO has mpi support but broken with virtual/mpi
-# local mycmakeargs=(
# $(cmake-utils_use mpi BUILD_LIBS_FOR_MPI)
-# )
+ local mycmakeargs=(
+ -DLIB=$(get_libdir)
+ )
cmake-utils_src_configure
}
-
-src_install() {
- cmake-utils_src_install
- mv "${ED}"/usr/{lib,$(get_libdir)} || die
-}