aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-09-28 13:30:51 +0200
committerJustin Lecher <jlec@gentoo.org>2014-09-28 13:30:51 +0200
commit837c1eec6cbdfb6889198fee4b19c4f309a53a6e (patch)
tree67cedec3c044e19e155e642008737fd120905767 /dev-cpp/icnc
parentdev-util/smartgit: Version BUmp (diff)
parentThe dependency needs to be on xblas[fortran] otherwise libxblas won't have th... (diff)
downloadsci-837c1eec6cbdfb6889198fee4b19c4f309a53a6e.tar.gz
sci-837c1eec6cbdfb6889198fee4b19c4f309a53a6e.tar.bz2
sci-837c1eec6cbdfb6889198fee4b19c4f309a53a6e.zip
Merge remote-tracking branch 'github/master'
* github/master: The dependency needs to be on xblas[fortran] otherwise libxblas won't have the required fortran symbols. live ebuild update Add xblas to the .pc file when it is in use see bug#523388 initial commit
Diffstat (limited to 'dev-cpp/icnc')
-rw-r--r--dev-cpp/icnc/ChangeLog12
-rw-r--r--dev-cpp/icnc/icnc-9999.ebuild39
-rw-r--r--dev-cpp/icnc/metadata.xml8
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-cpp/icnc/ChangeLog b/dev-cpp/icnc/ChangeLog
new file mode 100644
index 000000000..d402c65e3
--- /dev/null
+++ b/dev-cpp/icnc/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-cpp/icnc
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 25 Sep 2014; Christoph Junghans <ottxor@gentoo.org> icnc-9999.ebuild:
+ live ebuild update
+
+*icnc-9999 (25 Sep 2014)
+
+ 25 Sep 2014; Christoph Junghans <ottxor@gentoo.org> +icnc-9999.ebuild,
+ +metadata.xml:
+ initial commit
diff --git a/dev-cpp/icnc/icnc-9999.ebuild b/dev-cpp/icnc/icnc-9999.ebuild
new file mode 100644
index 000000000..aeee540a9
--- /dev/null
+++ b/dev-cpp/icnc/icnc-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+DESCRIPTION="Intel Concurrent Collections for C++ - Parallelism without the Pain"
+HOMEPAGE="https://software.intel.com/en-us/articles/intel-concurrent-collections-for-cc"
+
+if [[ $PV = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/icnc/icnc.git"
+ KEYWORDS=
+else
+ #SRC_URI="mirror://sourceforge/${PN}/${PV}/l_cnc_b_${PV}.tgz"
+ SRC_URI="https://github.com/martine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-cpp/tbb-4.2[debug]
+ sys-libs/glibc
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+#TODO has mpi support but broken with virtual/mpi
+# $(cmake-utils_use mpi BUILD_LIBS_FOR_MPI)
+ local mycmakeargs=(
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/icnc/metadata.xml b/dev-cpp/icnc/metadata.xml
new file mode 100644
index 000000000..745b9e1ce
--- /dev/null
+++ b/dev-cpp/icnc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+</pkgmetadata>