aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-12-08 12:03:46 -0700
committerChristoph Junghans <ottxor@gentoo.org>2014-12-09 10:58:23 -0700
commit9e2a159222788527db8ae706731918f872842e4b (patch)
treeddc6c0aebb1fad5de6f95308979464bb4158f985 /dev-cpp
parentOne more correction of 64 vs 32 bit integers handling in sci-chemistry/nwchem... (diff)
downloadsci-9e2a159222788527db8ae706731918f872842e4b.tar.gz
sci-9e2a159222788527db8ae706731918f872842e4b.tar.bz2
sci-9e2a159222788527db8ae706731918f872842e4b.zip
sync with gx86
Package-Manager: portage-2.2.14
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/icnc/ChangeLog3
-rw-r--r--dev-cpp/icnc/icnc-9999.ebuild29
2 files changed, 28 insertions, 4 deletions
diff --git a/dev-cpp/icnc/ChangeLog b/dev-cpp/icnc/ChangeLog
index 93bd9430d..133507f2f 100644
--- a/dev-cpp/icnc/ChangeLog
+++ b/dev-cpp/icnc/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 08 Dec 2014; Christoph Junghans <ottxor@gentoo.org> icnc-9999.ebuild:
+ sync with gx86
+
21 Nov 2014; Christoph Junghans <ottxor@gentoo.org> icnc-9999.ebuild:
fixed install location
diff --git a/dev-cpp/icnc/icnc-9999.ebuild b/dev-cpp/icnc/icnc-9999.ebuild
index 68a3a2927..8d4f5ddfd 100644
--- a/dev-cpp/icnc/icnc-9999.ebuild
+++ b/dev-cpp/icnc/icnc-9999.ebuild
@@ -4,7 +4,9 @@
EAPI=5
-inherit cmake-utils multilib
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils multilib python-any-r1
DESCRIPTION="Intel Concurrent Collections for C++ - Parallelism without the Pain"
HOMEPAGE="https://software.intel.com/en-us/articles/intel-concurrent-collections-for-cc"
@@ -20,14 +22,18 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="doc examples mpi"
+IUSE="doc examples mpi test"
+RESTRICT="test" #currently tests only work if icnc is already installed
-DEPEND="
+RDEPEND="
>=dev-cpp/tbb-4.2
sys-libs/glibc
mpi? ( virtual/mpi )
"
-RDEPEND="${DEPEND}"
+DEPEND="
+ ${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ "
src_configure() {
local mycmakeargs=(
@@ -35,6 +41,21 @@ src_configure() {
-DLIB=$(get_libdir)
)
cmake-utils_src_configure
+ if use test ; then
+ mycmakeargs=( -DRUN_DIST=OFF )
+ CMAKE_USE_DIR="${S}/tests" \
+ BUILD_DIR="${WORKDIR}/${P}_tests_build" \
+ cmake-utils_src_configure
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use test && BUILD_DIR="${WORKDIR}/${P}_tests_build" cmake-utils_src_compile
+}
+
+src_test() {
+ BUILD_DIR="${WORKDIR}/${P}_tests_build" cmake-utils_src_test
}
src_install() {