aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2011-06-08 21:15:05 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2011-06-08 21:15:05 -0400
commita3d6879ca1e3caad392c0968fcfd725448aadcb3 (patch)
treef4e244236dc0874328d816b4cfa7f516eb3daab7 /dev-java/jlatexmath/jlatexmath-0.9.4.ebuild
parentsci-visualization/v_sim: added maintainer email (diff)
downloadsci-a3d6879ca1e3caad392c0968fcfd725448aadcb3.tar.gz
sci-a3d6879ca1e3caad392c0968fcfd725448aadcb3.tar.bz2
sci-a3d6879ca1e3caad392c0968fcfd725448aadcb3.zip
[dev-java/jlatexmath] version bump
Diffstat (limited to 'dev-java/jlatexmath/jlatexmath-0.9.4.ebuild')
-rw-r--r--dev-java/jlatexmath/jlatexmath-0.9.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/jlatexmath/jlatexmath-0.9.4.ebuild b/dev-java/jlatexmath/jlatexmath-0.9.4.ebuild
new file mode 100644
index 000000000..ca954506d
--- /dev/null
+++ b/dev-java/jlatexmath/jlatexmath-0.9.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java API to render LaTeX"
+SRC_URI="http://forge.scilab.org/upload/jlatexmath/files/${PN}-src-${PV}.zip"
+HOMEPAGE="http://forge.scilab.org/index.php/p/jlatexmath"
+
+IUSE="doc examples source"
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+EANT_BUILD_TARGET="buildJar"
+EANT_DOC_TARGET="doc"
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ use doc && java-pkg_dojavadoc doc
+ use source && java-pkg_dosrc src/org
+ #use examples && java-pkg_doexamples examples
+ if use examples; then
+ eant examples
+ java-pkg_doexamples examples
+ fi
+}