aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2014-04-22 19:36:37 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2014-04-22 19:46:37 -0400
commitb7f75143d57366ad18699914d91e488968a1ef35 (patch)
tree31235a7e656ed42b5162f6b71c118d646c6a3130 /dev-java/jlatexmath/jlatexmath-1.0.3.ebuild
parentdev-java/jgraphx: version bump (diff)
downloadsci-b7f75143d57366ad18699914d91e488968a1ef35.tar.gz
sci-b7f75143d57366ad18699914d91e488968a1ef35.tar.bz2
sci-b7f75143d57366ad18699914d91e488968a1ef35.zip
dev-java/jlatexmath: version bump
Package-Manager: portage-2.2.10
Diffstat (limited to 'dev-java/jlatexmath/jlatexmath-1.0.3.ebuild')
-rw-r--r--dev-java/jlatexmath/jlatexmath-1.0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/jlatexmath/jlatexmath-1.0.3.ebuild b/dev-java/jlatexmath/jlatexmath-1.0.3.ebuild
new file mode 100644
index 000000000..96eaad9b6
--- /dev/null
+++ b/dev-java/jlatexmath/jlatexmath-1.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java API to render LaTeX"
+HOMEPAGE="http://forge.scilab.org/index.php/p/jlatexmath"
+SRC_URI="http://forge.scilab.org/upload/jlatexmath/files/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+EANT_BUILD_TARGET="buildJar"
+EANT_DOC_TARGET="doc"
+
+src_install() {
+ java-pkg_newjar dist/"${P}.jar" "${PN}.jar"
+ use doc && java-pkg_dojavadoc doc
+ use source && java-pkg_dosrc src/org
+ use examples && java-pkg_doexamples examples
+}