aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2012-05-15 00:52:20 +0100
committerSébastien Fabbro <sebfabbro@gmail.com>2012-05-15 00:52:20 +0100
commitaeda38db4156ee813f18dfef714657422b740d8f (patch)
treeee9694a0119f874377744da798e94768a9db190a /dev-java/joda-convert
parentdev-java/jrosetta: import from the java overlay (diff)
downloadsci-aeda38db4156ee813f18dfef714657422b740d8f.tar.gz
sci-aeda38db4156ee813f18dfef714657422b740d8f.tar.bz2
sci-aeda38db4156ee813f18dfef714657422b740d8f.zip
dev-java/joda-convert: import from the java overlay
(Portage version: 2.1.10.56/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-java/joda-convert')
-rw-r--r--dev-java/joda-convert/ChangeLog10
-rw-r--r--dev-java/joda-convert/Manifest1
-rw-r--r--dev-java/joda-convert/files/1.2-build.xml99
-rw-r--r--dev-java/joda-convert/joda-convert-1.2.ebuild44
-rw-r--r--dev-java/joda-convert/metadata.xml5
5 files changed, 159 insertions, 0 deletions
diff --git a/dev-java/joda-convert/ChangeLog b/dev-java/joda-convert/ChangeLog
new file mode 100644
index 000000000..2c2bbe4b6
--- /dev/null
+++ b/dev-java/joda-convert/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-java/joda-convert
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*joda-convert-1.2 (14 May 2012)
+
+ 14 May 2012; Sébastien Fabbro <bicatali@gentoo.org> +files/1.2-build.xml,
+ +joda-convert-1.2.ebuild, +metadata.xml:
+ dev-java/joda-convert: import from the java overlay
+
diff --git a/dev-java/joda-convert/Manifest b/dev-java/joda-convert/Manifest
new file mode 100644
index 000000000..5cc6d7868
--- /dev/null
+++ b/dev-java/joda-convert/Manifest
@@ -0,0 +1 @@
+DIST joda-convert-1.2-dist.tar.gz 124723 SHA256 510e15e9174a33af6bf8f52b4f24c14a2b02afdf8808cdb969bc18c3092b3fff SHA512 841b38558ee6a4ae4f781d2bef3720efa4a87fa001c3c9b4fda2cd8a3cc332c2bf2e91fa8ab8675d5b06d5c5368ea0634542c7bedee977f89b39731082dd4ab3 WHIRLPOOL b71db44ea79d3f0e6cca05f1f962b8391b25a06ccfb6ecb738d6cbcb6bb150b847540fcc4bb82fbff876838d622f989450c027cce63de391809a9125b1a7d796
diff --git a/dev-java/joda-convert/files/1.2-build.xml b/dev-java/joda-convert/files/1.2-build.xml
new file mode 100644
index 000000000..07fe6e0ad
--- /dev/null
+++ b/dev-java/joda-convert/files/1.2-build.xml
@@ -0,0 +1,99 @@
+<?xml version="1.0"?>
+<project name="Joda convert" default="all" basedir=".">
+ <target name="init" description="Sets build properties">
+ <!-- package configuration -->
+ <property name="package.version" value="devel"/>
+ <!-- directory locations -->
+ <property name="src" value="${basedir}/src"/>
+ <property name="src.lib" value="${src}/main/java"/>
+ <property name="src.test" value="${src}/test/java"/>
+ <property name="build" value="${basedir}/build"/>
+ <property name="build.lib" value="${build}/lib"/>
+ <property name="build.test" value="${build}/test"/>
+ <property name="doc" value="${basedir}/doc"/>
+ <property name="doc.api" value="${doc}/api"/>
+ <!-- external dependencies -->
+ <property name="junit.jar" value="junit.jar"/>
+ <!-- classpaths -->
+ <path id="project.class.path">
+ </path>
+ <path id="test.class.path">
+ <!--pathelement location="${junit.jar}"/--> <!-- handled by Gentoo's ANT_TASKS -->
+ </path>
+ <path id="build.lib.class.path">
+ <pathelement location="${build.lib}"/>
+ </path>
+ <path id="build.test.class.path">
+ <pathelement location="${build.test}"/>
+ </path>
+ </target>
+ <target name="all" depends="jar,javadoc"
+ description="Pseudo-target that builds JAR and Javadoc"/>
+ <target name="build-lib" depends="init"
+ description="Compiles the library classes">
+ <mkdir dir="${build.lib}"/>
+ <javac destdir="${build.lib}" srcdir="${src.lib}" debug="true"
+ deprecation="true" includeantruntime="false">
+ <classpath refid="project.class.path"/>
+ <classpath refid="build.lib.class.path"/>
+ <!--compilerarg line="-Xlint:unchecked"/-->
+ </javac>
+ <!--copy todir="${build}">
+ <mappedresources>
+ <fileset dir="${src}" includes="**/test/test.fits*"/>
+ <globmapper from="*" to="*"/>
+ </mappedresources>
+ </copy-->
+ </target>
+ <target name="build-tests" depends="build-lib"
+ description="Compiles the test classes">
+ <mkdir dir="${build.test}"/>
+ <javac destdir="${build.test}" srcdir="${src.test}" debug="true"
+ deprecation="true" includeantruntime="false">
+ <classpath refid="project.class.path"/>
+ <classpath refid="test.class.path"/>
+ <classpath refid="build.lib.class.path"/>
+ </javac>
+ </target>
+ <target name="build" depends="build-lib"
+ description="Alias for build-lib"/>
+ <target name="test" depends="build-tests">
+ <junit>
+ <classpath refid="project.class.path"/>
+ <classpath refid="test.class.path"/>
+ <classpath refid="build.lib.class.path"/>
+ <classpath refid="build.test.class.path"/>
+ <formatter type="brief" usefile="false" />
+ <batchtest>
+ <fileset dir="${build.test}">
+ <include name="**/*.class" />
+ <exclude name="**/*$*.class" />
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+ <target name="javadoc" depends="init"
+ description="Generates Javadoc API documentation">
+ <mkdir dir="${doc.api}"/>
+ <javadoc packagenames="*"
+ sourcepath="${src.lib}" destdir="${doc.api}"
+ author="true" version="true"
+ use="true" private="true"/>
+ </target>
+ <target name="jar" depends="build-lib"
+ description="Builds a project JAR file">
+ <jar basedir="${build.lib}" jarfile="${build}/joda-convert.jar">
+ <manifest>
+ <attribute name="Version" value="${package.version}"/>
+ </manifest>
+ </jar>
+ </target>
+ <target name="clean" depends="init"
+ description="Erase all generated files and dirs">
+ <delete dir="${build}" verbose="true"/>
+ <delete dir="${doc}" verbose="true"/>
+ <delete verbose="true">
+ <fileset dir="${basedir}" includes="*.jar"/>
+ </delete>
+ </target>
+</project>
diff --git a/dev-java/joda-convert/joda-convert-1.2.ebuild b/dev-java/joda-convert/joda-convert-1.2.ebuild
new file mode 100644
index 000000000..cf93e79d4
--- /dev/null
+++ b/dev-java/joda-convert/joda-convert-1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java library for conversion between Object and String"
+HOMEPAGE="http://joda-convert.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-dist.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ test? (
+ dev-java/ant-junit4
+ dev-java/hamcrest-core
+ )"
+RDEPEND=">=virtual/jre-1.5"
+
+JAVA_PKG_WANT_SOURCE="5"
+EANT_EXTRA_ARGS="-Dpacakge.version=${PV}"
+EANT_GENTOO_CLASSPATH="junit-4"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_prepare() {
+ cp "${FILESDIR}"/${PV}-build.xml build.xml
+}
+
+src_test() {
+ ANT_TASKS="ant-junit4" eant test
+}
+
+src_install() {
+ java-pkg_newjar build/${PN}.jar ${PN}.jar
+ dodoc NOTICE.txt RELEASE-NOTES.txt
+ use doc && java-pkg_dojavadoc doc/api
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/joda-convert/metadata.xml b/dev-java/joda-convert/metadata.xml
new file mode 100644
index 000000000..b229aec85
--- /dev/null
+++ b/dev-java/joda-convert/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>