aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-17 16:21:32 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-03-17 16:21:32 +0000
commit76ffb781ed7a917f23b67454e9f950e5e3b83527 (patch)
tree94fa8e1ddc7cb9ef80b78ea7896a5845f074f95b /dev-lang/aldor/aldor-1.1.0.ebuild
parentmove stuff to root (diff)
downloadsci-76ffb781ed7a917f23b67454e9f950e5e3b83527.tar.gz
sci-76ffb781ed7a917f23b67454e9f950e5e3b83527.tar.bz2
sci-76ffb781ed7a917f23b67454e9f950e5e3b83527.zip
moved overlay to new directory
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@979 32389bae-6d03-0410-99cf-db05cde120eb
Diffstat (limited to 'dev-lang/aldor/aldor-1.1.0.ebuild')
-rw-r--r--dev-lang/aldor/aldor-1.1.0.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-lang/aldor/aldor-1.1.0.ebuild b/dev-lang/aldor/aldor-1.1.0.ebuild
new file mode 100644
index 000000000..3f5e90a1f
--- /dev/null
+++ b/dev-lang/aldor/aldor-1.1.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+inherit subversion elisp-common
+
+DESCRIPTION="Aldor - programming language with a two-level type system"
+HOMEPAGE="http://www.aldor.org/"
+LICENSE="aldor-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc emacs"
+RDEPEND="emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}
+ dev-util/byacc
+ emacs? ( app-text/noweb doc? ( virtual/tetex ) )"
+ESVN_REPO_URI="https://aquarium.aldor.csd.uwo.ca/svn/trunk"
+SRC_URI="doc? ( http://aldor.org/docs/aldorug.pdf.gz
+ http://aldor.org/docs/libaldor.pdf.gz
+ http://aldor.org/docs/tutorial.pdf.gz
+ ftp://ftp-sop.inria.fr/cafe/software/algebra/algebra.html.tar.gz )
+ emacs? ( http://www.risc.uni-linz.ac.at/people/hemmecke/aldor/aldor.el.nw )"
+
+src_compile() {
+ if use emacs; then
+ einfo "The aldor emacs mode"
+ notangle "${DISTDIR}/aldor.el.nw" > aldor.el
+ notangle -Rinit.el "${DISTDIR}/aldor.el.nw" | \
+ sed -e '1s/^.*$/;; aldor mode/' > 64aldor-gentoo.el
+ if use doc; then
+ einfo "Documentation for the aldor emacs mode"
+ noweave "${DISTDIR}/aldor.el.nw" > aldor-mode.tex
+ pdflatex aldor-mode.tex
+ pdflatex aldor-mode.tex
+ fi
+ fi
+ if use doc; then
+ einfo "Documentation"
+ cp "${DISTDIR}/aldorug.pdf.gz" .
+ cp "${DISTDIR}/libaldor.pdf.gz" .
+ cp "${DISTDIR}/tutorial.pdf.gz" .
+ gunzip aldorug.pdf.gz libaldor.pdf.gz tutorial.pdf.gz
+ tar xzf "${DISTDIR}/algebra.html.tar.gz"
+ fi
+ cd "${PN}"
+ einfo "Compiling aldor and its libraries"
+ epatch "${FILESDIR}/${P}.patch"
+ emake distrib
+}
+
+src_install() {
+ cd "${S}"
+ cat > 64aldor <<EOF
+ALDORROOT=/opt/${PN}/linux/${PV}
+PATH=/opt/${PN}/linux/${PV}/bin
+EOF
+ doenvd 64aldor
+ if use doc; then
+ einfo "Installing the aldor documentation"
+ insinto "/usr/share/doc/${P}"
+ doins *.pdf
+ doins -r algebra.html
+ fi
+ if use emacs; then
+ einfo "Installing the aldor emacs mode"
+ elisp-site-file-install aldor.el
+ elisp-site-file-install 64aldor-gentoo.el
+ fi
+ einfo "Installing aldor and its libraries"
+ cd "${PN}/install"
+ dodir /opt
+ cp -a "${PN}" "${D}opt/"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_prerm() {
+ [ -f "${SITELISP}/site-gentoo.el" ] && elisp-site-regen
+}