aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-11-05 15:00:58 -0700
committerChristoph Junghans <ottxor@gentoo.org>2013-11-05 15:00:58 -0700
commit385ef6d33f3f6a1932483c12773ce376b7b2ed6f (patch)
treef0cf72000f9bb5fcacb3bc91ddc9be2c46b30356 /dev-lang/conceptual/conceptual-1.4.ebuild
parentsci-libs/libxc: Version BUmp; fix compilation problem with gcc-4.8, #488470 (diff)
downloadsci-385ef6d33f3f6a1932483c12773ce376b7b2ed6f.tar.gz
sci-385ef6d33f3f6a1932483c12773ce376b7b2ed6f.tar.bz2
sci-385ef6d33f3f6a1932483c12773ce376b7b2ed6f.zip
initial commit
Package-Manager: portage-2.2.7
Diffstat (limited to 'dev-lang/conceptual/conceptual-1.4.ebuild')
-rw-r--r--dev-lang/conceptual/conceptual-1.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lang/conceptual/conceptual-1.4.ebuild b/dev-lang/conceptual/conceptual-1.4.ebuild
new file mode 100644
index 000000000..801df9ef5
--- /dev/null
+++ b/dev-lang/conceptual/conceptual-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+JAVA_PKG_IUSE="gui"
+
+inherit java-pkg-opt-2 python-single-r1
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A Network Correctness and Performance Testing Language"
+HOMEPAGE="http://conceptual.sourceforge.net/"
+
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="gui test"
+
+RDEPEND="virtual/mpi
+ ${PYTHON_DEPS}
+ gui? ( virtual/jdk dev-java/jython )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ default
+ addread /usr/share/jython
+ use gui && emake gui
+}
+
+src_install () {
+ default
+ if use gui; then
+ java-pkg_newjar gui/ncptlGUI-1.4.jar ${PN}.jar
+ java-pkg_dolauncher
+ fi
+}