aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <kislyuk@onyx.(none)>2009-10-11 14:45:02 -0400
committerAndrey Kislyuk <kislyuk@onyx.(none)>2009-10-11 14:45:02 -0400
commitfb3a92df380fab191ddd596758018afdb90c94f4 (patch)
treef4c2cc950373298f019e2007e9d7f262831d025e /dev-lang/icc
parentMerge branch 'master' of git+ssh://git@git.overlays.gentoo.org/proj/sci (diff)
downloadsci-fb3a92df380fab191ddd596758018afdb90c94f4.tar.gz
sci-fb3a92df380fab191ddd596758018afdb90c94f4.tar.bz2
sci-fb3a92df380fab191ddd596758018afdb90c94f4.zip
Bump ICC 10 series per bug 284801
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/Manifest4
-rw-r--r--dev-lang/icc/icc-10.1.025.ebuild119
2 files changed, 123 insertions, 0 deletions
diff --git a/dev-lang/icc/Manifest b/dev-lang/icc/Manifest
new file mode 100644
index 000000000..e94f9092c
--- /dev/null
+++ b/dev-lang/icc/Manifest
@@ -0,0 +1,4 @@
+DIST l_cc_p_10.1.025_ia32.tar.gz 51174422 RMD160 ffba6c79c0757fa9ca9bfb468405906df4aac551 SHA1 f2900d53e087ab3e7a61410ebcc59eb75ff47553 SHA256 3097dfa8c394acb7c6ba959fcfa0b6c8d2e5a1ebe9990ec992b1dc2d527c7058
+DIST l_cc_p_10.1.025_ia64.tar.gz 73391074 RMD160 e309b3b5740d2d898af82eff928df42d611e2355 SHA1 c347abc95d499160b754e2226427e506a25843a2 SHA256 90b2e7d390bc58c721edd88d4df7936b9f23470eb97761b1ee1045f654f6c161
+DIST l_cc_p_10.1.025_intel64.tar.gz 40795489 RMD160 276d39902013be9455e181e73f450e05268b6da8 SHA1 053a9e16fc69b6fe45eaeaa5650a4a8035e986cd SHA256 117615b9f34de5d416c10e41f7d1a31063ccab816b12708f01cdc1cc450f7e9f
+EBUILD icc-10.1.025.ebuild 3157 RMD160 0284dfd5f64f064c9421c8536aee09ca1d58ff61 SHA1 e5f3be784c7a4df4d2061dd74ee58961b8304a5f SHA256 18c0cd12986d34a703062271bdf9c4d10da95aff248cb3686ed10cd2d0e03680
diff --git a/dev-lang/icc/icc-10.1.025.ebuild b/dev-lang/icc/icc-10.1.025.ebuild
new file mode 100644
index 000000000..d49b5737a
--- /dev/null
+++ b/dev-lang/icc/icc-10.1.025.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-10.1.018.ebuild,v 1.5 2009/08/22 20:29:05 williamh Exp $
+
+inherit rpm eutils check-reqs
+
+PID=1569
+PB=cc
+PEXEC="icc icpc"
+DESCRIPTION="Intel C/C++ optimized compiler for Linux"
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+
+###
+# everything below common to ifc and icc
+# no eclass: very likely to change for next versions
+###
+PACKID="l_${PB}_p_${PV}"
+KEYWORDS="~amd64 ~ia64 ~x86"
+SRC_COM="http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKID}"
+SRC_URI="amd64? ( ${SRC_COM}_intel64.tar.gz )
+ ia64? ( ${SRC_COM}_ia64.tar.gz )
+ x86? ( ${SRC_COM}_ia32.tar.gz )"
+
+LICENSE="Intel-SDP"
+SLOT="0"
+
+RESTRICT="test strip mirror"
+IUSE=""
+DEPEND=""
+RDEPEND="~virtual/libstdc++-3.3
+ amd64? ( app-emulation/emul-linux-x86-compat )"
+
+pkg_setup() {
+ # Check if we have enough RAM and free diskspace
+ CHECKREQS_MEMORY="512"
+ local disk_req="300"
+ use amd64 && disk_req="400"
+ use ia64 && disk_req="350"
+ CHECKREQS_DISK_BUILD=${disk_req}
+ check_reqs
+}
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}"/l_* "${S}"
+ cd "${S}"
+
+ local ext=
+ use amd64 && ext=e
+ INSTALL_DIR=/opt/intel/${PB}${ext}/${PV}
+
+ # debugger installed with dev-lang/idb
+ rm -f data/intel*idb*.rpm
+
+ for x in data/intel*.rpm; do
+ einfo "Extracting $(basename ${x})..."
+ rpm_unpack "${S}/${x}" || die "rpm_unpack ${x} failed"
+ done
+
+ einfo "Fixing paths and tagging"
+ cd "${S}"/${INSTALL_DIR}/bin
+ sed -e "s|<INSTALLDIR>|${INSTALL_DIR}|g" \
+ -e 's|export -n IA32ROOT;||g' \
+ -i ${PEXEC} *sh \
+ || die "sed fixing shells and paths failed"
+
+ cd "${S}"/${INSTALL_DIR}/doc
+ sed -e "s|\<installpackageid\>|${PACKID}|g" \
+ -e "s|\<INSTALLTIMECOMBOPACKAGEID\>|${PACKID}|g" \
+ -i *support \
+ || die "sed support file failed"
+ chmod 644 *support
+
+ if use amd64; then
+ cat <<-EOF >>"${S}"/${INSTALL_DIR}/bin/icc.cfg
+ -D__amd64=__x86_64
+ -D__amd64__=__x86_64__
+ -idirafter /usr/include/linux
+ EOF
+ cat <<-EOF >>"${S}"/${INSTALL_DIR}/bin/icpc.cfg
+ -D__amd64=__x86_64
+ -D__amd64__=__x86_64__
+ -idirafter /usr/include/linux
+ EOF
+ fi
+}
+
+src_install() {
+ einfo "Copying files"
+ dodir ${INSTALL_DIR}
+ cp -pPR \
+ "${S}"/${INSTALL_DIR}/* \
+ "${D}"/${INSTALL_DIR}/ \
+ || die "Copying ${PN} failed"
+
+ local env_file=05${PN}
+ cat > ${env_file} <<-EOF
+ PATH=${INSTALL_DIR}/bin
+ ROOTPATH=${INSTALL_DIR}/bin
+ LDPATH=${INSTALL_DIR}/lib
+ MANPATH=${INSTALL_DIR}/man
+ EOF
+ doenvd ${env_file} || die "doenvd ${env_file} failed"
+}
+
+pkg_postinst () {
+ # remove left over from unpacking
+ rm -f "${ROOT}"/opt/intel/{intel_sdp_products.db,.*.log} \
+ || die "remove logs failed"
+
+ elog "Make sure you have recieved the a license for ${PN},"
+ elog "you cannot run ${PN} without a license file."
+ elog "To receive a non-commercial license, you need to register."
+ elog "Read the website for more information on this license:"
+ elog "${HOMEPAGE}"
+ elog "Then put the license file into ${ROOT}/opt/intel/licenses."
+ elog "\nTo use ${PN} issue first \n\tsource ${ROOT}/etc/profile"
+ elog "Debugger is installed with dev-lang/idb"
+}