aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-05-31 17:25:55 -0600
committerChristoph Junghans <ottxor@gentoo.org>2013-05-31 17:26:53 -0600
commit1cc55beacf5fcb9b047639e777af5a385eae852b (patch)
tree6f1eeeba7a09a690e50eaa5851a70bf1c699268f /dev-lang/ispc
parentMerge branch 'master' of github.com:gentoo-science/sci (diff)
downloadsci-1cc55beacf5fcb9b047639e777af5a385eae852b.tar.gz
sci-1cc55beacf5fcb9b047639e777af5a385eae852b.tar.bz2
sci-1cc55beacf5fcb9b047639e777af5a385eae852b.zip
sync with gx86
Package-Manager: portage-2.2.0_alpha177
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ChangeLog3
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild13
2 files changed, 7 insertions, 9 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index e87b0c01b..8c34eaf29 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 31 May 2013; Christoph Junghans <ottxor@gentoo.org> ispc-9999.ebuild:
+ sync with gx86
+
08 Jan 2013; Christoph Junghans <ottxor@gentoo.org> ispc-9999.ebuild:
fixed python dep
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
index e65b5c1b0..e22c4bac8 100644
--- a/dev-lang/ispc/ispc-9999.ebuild
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.3.0.ebuild,v 1.2 2012/07/20 19:58:21 ottxor Exp $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="2"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit base toolchain-funcs python
+inherit base toolchain-funcs python-any-r1
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="http://ispc.github.com/"
@@ -15,8 +15,7 @@ if [[ ${PV} = *9999 ]]; then
inherit git-2
EGIT_REPO_URI="git://github.com/ispc/ispc.git"
else
- inherit vcs-snapshot
- SRC_URI="https://github.com/${PN}/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="BSD BSD-2 UoI-NCSA"
@@ -34,10 +33,6 @@ DEPEND="
sys-devel/flex
"
-pkg_setup() {
- python_set_active_version 2
-}
-
src_compile() {
emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
}