aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-01-07 21:35:19 -0700
committerChristoph Junghans <ottxor@gentoo.org>2013-01-07 21:36:35 -0700
commit51824bb37562772d7a02adabda11528e4f091886 (patch)
treef9239ceecb75d67907012fb7749ad471a0dc89e5 /dev-lang/ispc
parentsci-mathematics/scilab-5.4.0 cleanup dependencies (diff)
downloadsci-51824bb37562772d7a02adabda11528e4f091886.tar.gz
sci-51824bb37562772d7a02adabda11528e4f091886.tar.bz2
sci-51824bb37562772d7a02adabda11528e4f091886.zip
fixed python dep
Package-Manager: portage-2.2.0_alpha149
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ChangeLog5
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index 81a6141b9..e87b0c01b 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for dev-lang/ispc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 08 Jan 2013; Christoph Junghans <ottxor@gentoo.org> ispc-9999.ebuild:
+ fixed python dep
+
26 Aug 2012; Christoph Junghans <ottxor@gentoo.org> ispc-9999.ebuild:
sync with gx86
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
index f1c513068..e65b5c1b0 100644
--- a/dev-lang/ispc/ispc-9999.ebuild
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.3.0.ebuild,v 1.2 2012/07/20 19:58:21 ottxor Exp $
EAPI=4
-inherit base toolchain-funcs
+PYTHON_DEPEND="2"
+
+inherit base toolchain-funcs python
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="http://ispc.github.com/"
@@ -32,6 +34,10 @@ DEPEND="
sys-devel/flex
"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_compile() {
emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
}