aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-26 12:32:39 -0600
committerChristoph Junghans <ottxor@gentoo.org>2012-08-26 12:32:39 -0600
commitf76906d097da4e564e3c0f7dd05753ff5c1a7a6c (patch)
treece35d1285c9e5b5bbbf73724c5bc652d17117478 /dev-lang/ispc
parentrenamed -bin (diff)
downloadsci-f76906d097da4e564e3c0f7dd05753ff5c1a7a6c.tar.gz
sci-f76906d097da4e564e3c0f7dd05753ff5c1a7a6c.tar.bz2
sci-f76906d097da4e564e3c0f7dd05753ff5c1a7a6c.zip
sync with gx86
(Portage version: 2.2.0_alpha122/git/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ChangeLog4
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild18
2 files changed, 14 insertions, 8 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index 04f5d93d1..81a6141b9 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 26 Aug 2012; Christoph Junghans <ottxor@gentoo.org> ispc-9999.ebuild:
+ sync with gx86
+
17 Jun 2012; Christoph Junghans <ottxor@gentoo.org> ispc-9999.ebuild:
fixed redundant license (bug #421401)
@@ -10,4 +13,3 @@
14 Jun 2012; Christoph Junghans <ottxor@gentoo.org> +ispc-9999.ebuild,
+metadata.xml:
initial commit
-
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
index 39310520e..f1c513068 100644
--- a/dev-lang/ispc/ispc-9999.ebuild
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -1,20 +1,25 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.2.2.ebuild,v 1.1 2012/06/14 17:31:34 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.3.0.ebuild,v 1.2 2012/07/20 19:58:21 ottxor Exp $
EAPI=4
-inherit git-2 toolchain-funcs
+inherit base toolchain-funcs
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="http://ispc.github.com/"
-SRC_URI=""
-EGIT_REPO_URI="git://github.com/ispc/ispc.git"
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ispc/ispc.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/${PN}/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+fi
LICENSE="BSD BSD-2 UoI-NCSA"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="examples"
RDEPEND="
@@ -27,14 +32,13 @@ DEPEND="
sys-devel/flex
"
-DOCS=( README.rst )
-
src_compile() {
emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
}
src_install() {
dobin ispc
+ dodoc README.rst
if use examples; then
insinto "/usr/share/doc/${PF}/examples"