aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-29 12:30:08 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-29 12:30:08 +0000
commit6707305d8d26969571e92f7acbb6031d47019b62 (patch)
treec9e9eed4996a58593dd50f20093c9d73bd3e30d2 /dev-lang/path64
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-6707305d8d26969571e92f7acbb6031d47019b62.tar.gz
sci-6707305d8d26969571e92f7acbb6031d47019b62.tar.bz2
sci-6707305d8d26969571e92f7acbb6031d47019b62.zip
dev-lang/path64: QA fixes
Bump to6 EAPI drop non active code add missing die Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-lang/path64')
-rw-r--r--dev-lang/path64/path64-9999.ebuild30
1 files changed, 11 insertions, 19 deletions
diff --git a/dev-lang/path64/path64-9999.ebuild b/dev-lang/path64/path64-9999.ebuild
index ed6c7690c..3f4465532 100644
--- a/dev-lang/path64/path64-9999.ebuild
+++ b/dev-lang/path64/path64-9999.ebuild
@@ -1,26 +1,18 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-if [ "${PV%9999}" != "${PV}" ] ; then
- SCM=git-r3
- EGIT_REPO_URI="git://github.com/pathscale/${PN}-suite.git"
- PATH64_URI="compiler assembler"
- PATHSCALE_URI="compiler-rt libcxxrt libdwarf-bsd libunwind stdcxx"
- DBG_URI="git://github.com/path64/debugger.git"
-fi
-
-inherit cmake-utils ${SCM} multilib toolchain-funcs
+inherit cmake-utils git-r3 toolchain-funcs
DESCRIPTION="Path64 Compiler Suite Community Edition"
HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
-if [ "${PV%9999}" != "${PV}" ] ; then
- SRC_URI=""
-else
- SRC_URI="" # for tarballs
-fi
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/pathscale/${PN}-suite.git"
+PATH64_URI="compiler assembler"
+PATHSCALE_URI="compiler-rt libcxxrt libdwarf-bsd libunwind stdcxx"
+DBG_URI="git://github.com/path64/debugger.git"
LICENSE="GPL-3"
SLOT="0"
@@ -29,7 +21,7 @@ IUSE="assembler custom-cflags debugger fortran +native +openmp valgrind"
DEPEND="
!native? ( sys-devel/gcc:*[vanilla] )
- native? ( || ( dev-lang/ekopath dev-lang/path64 ) )
+ native? ( || ( dev-lang/ekopath:* dev-lang/path64 ) )
valgrind? ( dev-util/valgrind )"
RDEPEND="${DEPEND}"
@@ -46,8 +38,8 @@ pkg_setup() {
src_unpack() {
git-r3_src_unpack
- cd "${S}"
- mkdir compiler
+ cd "${S}" || die
+ mkdir compiler || die
for f in ${PATH64_URI}; do
EGIT_REPO_URI="git://github.com/${PN}/${f}.git" \
EGIT_DIR="${EGIT_STORE_DIR}/compiler/${f}" \