aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-04-23 18:19:45 -0600
committerChristoph Junghans <ottxor@gentoo.org>2015-04-23 18:20:32 -0600
commitb35c23f20c86094faac92f2420fe2727d21a4f35 (patch)
tree3b039e444221acc297595cf0406ffd0e9227c0b6 /dev-lang/terra/terra-2015.03.12.ebuild
parentVersion bump to sci-physics/abinit-7.10.4, dependency for USE=bigdft changed ... (diff)
downloadsci-b35c23f20c86094faac92f2420fe2727d21a4f35.tar.gz
sci-b35c23f20c86094faac92f2420fe2727d21a4f35.tar.bz2
sci-b35c23f20c86094faac92f2420fe2727d21a4f35.zip
initial commit
thx to @zdevito for the nice intro to it Package-Manager: portage-2.2.18
Diffstat (limited to 'dev-lang/terra/terra-2015.03.12.ebuild')
-rw-r--r--dev-lang/terra/terra-2015.03.12.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/terra/terra-2015.03.12.ebuild b/dev-lang/terra/terra-2015.03.12.ebuild
new file mode 100644
index 000000000..5faa4cc26
--- /dev/null
+++ b/dev-lang/terra/terra-2015.03.12.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="A low-level counterpart to Lua"
+HOMEPAGE="http://terralang.org/"
+#cannot be unbundled easily, because needs to compiled with clang
+LUAJIT="LuaJIT-2.0.3.tar.gz"
+SRC_URI="https://github.com/zdevito/terra/archive/release-${PV//./-}.tar.gz -> ${P}.tar.gz
+ http://luajit.org/download/${LUAJIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="sys-devel/clang
+ dev-lang/luajit:2"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mv "${PN}"-* "${S}" || die
+ ln -s "${DISTDIR}/${LUAJIT}" "${S}/build" || die
+}
+
+src_install() {
+ cd release || die
+ dobin terra
+ dolib.so libterra.so
+ dodoc README.md
+ cd include || die
+ doheader terra.h *.t
+}