aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-05-05 00:16:42 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-05-05 01:04:48 -0500
commit1a8e3258d5ca7a8c899aa7e9a2810606a9b3411b (patch)
tree104e54b69128da91c34b7fcba99028e3f6d41693 /dev-lang/vtune
parentdev-lang/ifc: version bump to 2020 update 1 (diff)
downloadsci-1a8e3258d5ca7a8c899aa7e9a2810606a9b3411b.tar.gz
sci-1a8e3258d5ca7a8c899aa7e9a2810606a9b3411b.tar.bz2
sci-1a8e3258d5ca7a8c899aa7e9a2810606a9b3411b.zip
dev-lang/vtune: version bump to 2020 update 1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-lang/vtune')
-rw-r--r--dev-lang/vtune/Manifest1
-rw-r--r--dev-lang/vtune/metadata.xml13
-rw-r--r--dev-lang/vtune/vtune-2020.1.0.607630.ebuild52
3 files changed, 63 insertions, 3 deletions
diff --git a/dev-lang/vtune/Manifest b/dev-lang/vtune/Manifest
index e20607e91..0007a0681 100644
--- a/dev-lang/vtune/Manifest
+++ b/dev-lang/vtune/Manifest
@@ -1,2 +1,3 @@
DIST parallel_studio_xe_2018_update2_professional_edition.tgz 3877755304 BLAKE2B c8852df23abf080f482002a37af7781b3fbae3ecec448914ea5a237fa2b925073d1a3dc2dd94ba64002ff0f6c7e9b18b25fa7ada811a83b10344eb9b92cb37ff SHA512 a9b644b0305d83a9d0daa14d146cb3ce79949db55a410afe48d62259414e6256d9ef533a04bb50807103511db2016c4abcbbf769146854a25638f402a6d0f2be
DIST parallel_studio_xe_2019_update4_professional_edition.tgz 2629662464 BLAKE2B a5619f33535063ccd7310378504ca960aa8512527cef7e0884fae5570633c1823e50ff7135adbbc571b4d47e0b6fcc01afe8639e09feb50a7f289eeec3f61ca0 SHA512 d8f6780a3671f30a1bad5d3a9792062c73b31188dc31fbd38212e98abc593f1c8f64bb970a8a4fce9ce237afef18ed38adf8fd81aa73b63ec964224590d4a34d
+DIST parallel_studio_xe_2020_update1_professional_edition.tgz 2783012958 BLAKE2B 975103ec4551a0e3bd84034ce771a5fc459d5de47f4247b5915b54d9c827e50e913f9054a103424b764f730190675d42b52a97e68551b34df6b3d8d9b922517a SHA512 00a3334bcdb8b30216ecb40fcfc709b27d043697606a53f522c90b05cf8598e1e60311d629ec17b6fe1016a7d2a27f4b428abddc9eba39badebfd8a9b53de404
diff --git a/dev-lang/vtune/metadata.xml b/dev-lang/vtune/metadata.xml
index c46d15bb3..718cc299c 100644
--- a/dev-lang/vtune/metadata.xml
+++ b/dev-lang/vtune/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>nbigaouette@gmail.com</email>
- <name>Nicolas Bigaouette</name>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
</maintainer>
+ <longdescription lang="en">
+The Intel® VTune™ Profiler collects key profiling data and presents
+it with a powerful interface that simplifies its analysis and
+interpretation. The package comes with extensive documentation. The
+product can be installed as a non-commercial as well. License, terms
+of qualifications can be found on the web site.
+</longdescription>
</pkgmetadata>
diff --git a/dev-lang/vtune/vtune-2020.1.0.607630.ebuild b/dev-lang/vtune/vtune-2020.1.0.607630.ebuild
new file mode 100644
index 000000000..e1ec58882
--- /dev/null
+++ b/dev-lang/vtune/vtune-2020.1.0.607630.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+INTEL_DIST_PV=2020_update1_professional_edition
+INTEL_SUBDIR=vtune_profiler
+
+inherit intel-sdp-r1
+
+DESCRIPTION="Intel VTune Profiler"
+HOMEPAGE="https://software.intel.com/en-us/vtune"
+
+IUSE="doc"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="~dev-libs/intel-common-19.1.1.217[compiler]"
+
+MY_PV="$(ver_rs 3 '-')" # 20.1.0-607630
+
+QA_PREBUILT="*"
+
+INTEL_DIST_DAT_RPMS=(
+ "vtune-profiler-2020-cli-common-${MY_PV}.noarch.rpm"
+ "vtune-profiler-2020-common-${MY_PV}.noarch.rpm"
+ "vtune-profiler-2020-common-pset-${MY_PV}.noarch.rpm"
+ "vtune-profiler-2020-sep-${MY_PV}.noarch.rpm"
+ "vtune-profiler-2020-target-${MY_PV}.noarch.rpm")
+INTEL_DIST_AMD64_RPMS=(
+ "vtune-profiler-2020-cli-${MY_PV}.x86_64.rpm"
+ "vtune-profiler-2020-collector-64linux-${MY_PV}.x86_64.rpm"
+ "vtune-profiler-2020-gui-${MY_PV}.x86_64.rpm"
+ "vtune-profiler-2020-vpp-server-${MY_PV}.x86_64.rpm")
+INTEL_DIST_X86_RPMS=(
+ "vtune-profiler-2020-cli-32bit-${MY_PV}.i486.rpm"
+ "vtune-profiler-2020-collector-32linux-${MY_PV}.i486.rpm")
+
+pkg_setup() {
+ if use doc; then
+ INTEL_DIST_DAT_RPMS+=( "vtune-profiler-2020-doc-${MY_PV}.noarch.rpm" )
+ fi
+}
+
+src_install() {
+ intel-sdp-r1_src_install
+
+ local path="PATH="
+ use abi_x86_64 && path+=":$(isdp_get-sdp-edir)/bin64"
+ use abi_x86_32 && path+=":$(isdp_get-sdp-edir)/bin32"
+ echo "${path}" > "${T}"/35vtune || die
+ doenvd "${T}"/35vtune
+}