aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-06-14 11:30:50 -0700
committerChristoph Junghans <ottxor@gentoo.org>2012-06-14 11:30:50 -0700
commitdef8995a7d62680dbb42681c62ca7c8d2c0cb9e8 (patch)
tree924c5d32243b431008689d9f1398e5f1f088e5ef /dev-lang
parentmasked dev-lang/ispc-9999 (diff)
downloadsci-def8995a7d62680dbb42681c62ca7c8d2c0cb9e8.tar.gz
sci-def8995a7d62680dbb42681c62ca7c8d2c0cb9e8.tar.bz2
sci-def8995a7d62680dbb42681c62ca7c8d2c0cb9e8.zip
initial commit
(Portage version: 2.2.0_alpha110/git/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/ChangeLog10
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild44
-rw-r--r--dev-lang/ispc/metadata.xml8
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
new file mode 100644
index 000000000..d441c7951
--- /dev/null
+++ b/dev-lang/ispc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lang/ispc
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*ispc-9999 (14 Jun 2012)
+
+ 14 Jun 2012; Christoph Junghans <ottxor@gentoo.org> +ispc-9999.ebuild,
+ +metadata.xml:
+ initial commit
+
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
new file mode 100644
index 000000000..f45d86035
--- /dev/null
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.2.2.ebuild,v 1.1 2012/06/14 17:31:34 ottxor Exp $
+
+EAPI=4
+
+inherit git-2 toolchain-funcs
+
+DESCRIPTION="Intel SPMD Program Compiler"
+HOMEPAGE="http://ispc.github.com/"
+SRC_URI=""
+
+EGIT_REPO_URI="git://github.com/ispc/ispc.git"
+
+LICENSE="ispc"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=sys-devel/clang-3.0
+ >=sys-devel/llvm-3.0
+ "
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ "
+
+DOCS=( README.rst )
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
+}
+
+src_install() {
+ dobin ispc
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ docompress -x "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}
diff --git a/dev-lang/ispc/metadata.xml b/dev-lang/ispc/metadata.xml
new file mode 100644
index 000000000..745b9e1ce
--- /dev/null
+++ b/dev-lang/ispc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+</pkgmetadata>