aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-25 23:01:14 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-09-25 23:01:14 +0000
commitef66f5cc0415920b7b4a28f4f25f567c5436e66e (patch)
tree15c31fa6f928abc8ba00be8072253c31e1aca9ee /dev-libs/libunzip
parentdev-libs/simclist: various fixes and options (diff)
downloadsci-ef66f5cc0415920b7b4a28f4f25f567c5436e66e.tar.gz
sci-ef66f5cc0415920b7b4a28f4f25f567c5436e66e.tar.bz2
sci-ef66f5cc0415920b7b4a28f4f25f567c5436e66e.zip
dev-libs/libunzip: drop dead package
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-libs/libunzip')
-rw-r--r--dev-libs/libunzip/Manifest1
-rw-r--r--dev-libs/libunzip/files/libunzip-5.52-CVE-2008-0888.patch35
-rw-r--r--dev-libs/libunzip/files/libunzip-5.52-Makefile.patch31
-rw-r--r--dev-libs/libunzip/files/libunzip-5.52-no-exec-stack.patch13
-rw-r--r--dev-libs/libunzip/libunzip-5.52.ebuild51
-rw-r--r--dev-libs/libunzip/metadata.xml4
6 files changed, 0 insertions, 135 deletions
diff --git a/dev-libs/libunzip/Manifest b/dev-libs/libunzip/Manifest
deleted file mode 100644
index 596a7c553..000000000
--- a/dev-libs/libunzip/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST unzip552.tar.gz 1140291 BLAKE2B e761d44223fd566c6327a7030f52448217cce7516f61d86696ab0e0f8c9490ec63b9b941607348f7a3ad7819de7804e0a7c1b9106d1c85d93a1c26aa5fa35bba SHA512 9b852687a7cbce3a6696f8da176f97eded1e99b1f10ae5e4b29bf870df374fea3e4266b3a731d7cdfc28ce5c060a01dd8d3f9c3d8250d1d774273de16d70528b
diff --git a/dev-libs/libunzip/files/libunzip-5.52-CVE-2008-0888.patch b/dev-libs/libunzip/files/libunzip-5.52-CVE-2008-0888.patch
deleted file mode 100644
index 368b3eeb1..000000000
--- a/dev-libs/libunzip/files/libunzip-5.52-CVE-2008-0888.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-http://bugs.gentoo.org/213761
-
-fix for CVE-2008-0888
-
---- inflate.c
-+++ inflate.c
-@@ -983,6 +983,7 @@
- unsigned l; /* last length */
- unsigned m; /* mask for bit lengths table */
- unsigned n; /* number of lengths to get */
-+ struct huft *tlp;
- struct huft *tl; /* literal/length code table */
- struct huft *td; /* distance code table */
- unsigned bl; /* lookup bits for tl */
-@@ -996,6 +997,8 @@
- int retval = 0; /* error code returned: initialized to "no error" */
-
-
-+ td = tlp = tl = (struct huft *)NULL;
-+
- /* make local bit buffer */
- Trace((stderr, "\ndynamic block"));
- b = G.bb;
-@@ -1047,9 +1050,9 @@
- while (i < n)
- {
- NEEDBITS(bl)
-- j = (td = tl + ((unsigned)b & m))->b;
-+ j = (tlp = tl + ((unsigned)b & m))->b;
- DUMPBITS(j)
-- j = td->v.n;
-+ j = tlp->v.n;
- if (j < 16) /* length of code in bits (0..15) */
- ll[i++] = l = j; /* save last length in l */
- else if (j == 16) /* repeat last length 3 to 6 times */
diff --git a/dev-libs/libunzip/files/libunzip-5.52-Makefile.patch b/dev-libs/libunzip/files/libunzip-5.52-Makefile.patch
deleted file mode 100644
index b8787f2f2..000000000
--- a/dev-libs/libunzip/files/libunzip-5.52-Makefile.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- unix/Makefile 2005-02-26 20:58:34.000000000 +0100
-+++ unix/Makefile.new 2009-04-12 19:49:56.000000000 +0200
-@@ -45,6 +45,7 @@
- CC = cc# try using "gcc" target rather than changing this (CC and LD
- LD = $(CC)# must match, else "unresolved symbol: ___main" is possible)
- AS = as
-+RANLIB =
- LOC = $(LOCAL_UNZIP)
- AF = $(LOC)
- CF = -O -I. -DUNIX $(LOC)
-@@ -810,14 +810,14 @@
- #
- linux_shlib: unix_make
- # $(MAKE) objsdll CC=gcc CF="-O3 -Wall -I. -fPIC -DDLL $(LOC)"
-- $(MAKE) objsdll CC=gcc CF="-O3 -Wall -I. -fPIC -DDLL -DASM_CRC $(LOC)"\
-- AS=gcc AF="-fPIC -Di386 $(AF)" CRC32=crc_gcc
-- ln -sf crc_gcc.pic.o crc32.pic.o
-- gcc -shared -Wl,-soname,libunzip.so.0 -o libunzip.so.0.4 $(OBJSDLL)
-+ $(MAKE) objsdll CC=gcc CF="-O3 -Wall -I. -fPIC -DDLL -DUNIX $(LOC)"
-+ $(LD) $(LDFLAGS) -shared -Wl,-soname,libunzip.so.0 -o libunzip.so.0.4 $(OBJSDLL)
-+ $(AR) $(ARFLAGS) libunzip.a $(OBJSDLL)
-+ $(RANLIB) libunzip.a
- ln -sf libunzip.so.0.4 libunzip.so.0
- ln -sf libunzip.so.0 libunzip.so
-- gcc -c -O unzipstb.c
-- gcc -o unzip_shlib unzipstb.o -L. -lunzip
-+ $(CC) $(CFLAGS) -c unzipstb.c
-+ $(LD) $(LDFLAGS) -o unzip_shlib unzipstb.o -L. -lunzip
-
- # Linux ELF shared library, as above, but using inflate() from zlib (libz.so)
- # instead of the original UnZip version. (libz was libgz prior to 0.94)
diff --git a/dev-libs/libunzip/files/libunzip-5.52-no-exec-stack.patch b/dev-libs/libunzip/files/libunzip-5.52-no-exec-stack.patch
deleted file mode 100644
index e2869bfe8..000000000
--- a/dev-libs/libunzip/files/libunzip-5.52-no-exec-stack.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Make sure that the asm files don't incorrectly trigger an executable
-stack marking in the final shared library. That's bad, mmmkay.
-
---- unzip/crc_i386.S
-+++ unzip/crc_i386.S
-@@ -238,3 +238,7 @@
- #endif /* i386 || _i386 || _I386 || __i386 */
-
- #endif /* !USE_ZLIB */
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",%progbits
-+#endif
diff --git a/dev-libs/libunzip/libunzip-5.52.ebuild b/dev-libs/libunzip/libunzip-5.52.ebuild
deleted file mode 100644
index 15f6ae723..000000000
--- a/dev-libs/libunzip/libunzip-5.52.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_PN="${PN#lib}"
-
-DESCRIPTION="libunzip.so"
-HOMEPAGE="http://www.info-zip.org/"
-SRC_URI="mirror://gentoo/${MY_PN}${PV/.}.tar.gz"
-
-LICENSE="Info-ZIP"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-no-exec-stack.patch \
- "${FILESDIR}"/${P}-CVE-2008-0888.patch \
- "${FILESDIR}"/${P}-Makefile.patch
- sed -i \
- -e 's:-O3:$(CFLAGS) $(CPPFLAGS):' \
- -e 's:-O :$(CFLAGS) $(CPPFLAGS) :' \
- -e "s:CC=gcc :CC=$(tc-getCC) :" \
- -e "s:CC = cc:CC=$(tc-getCC) :" \
- -e "s:LD=gcc :LD=$(tc-getCC) :" \
- -e "s:AS=gcc :AS=$(tc-getCC) :" \
- -e "s:RANLIB =:RANLIB = $(tc-getRANLIB) :" \
- -e 's:LF2 = -s:LF2 = :' \
- -e 's:LF = :LF = $(LDFLAGS) :' \
- -e 's:SL = :SL = $(LDFLAGS) :' \
- -e 's:FL = :FL = $(LDFLAGS) :' \
- unix/Makefile \
- || die "sed unix/Makefile failed"
-}
-
-src_compile() {
- append-lfs-flags #104315
- emake -f unix/Makefile linux_shlib
-}
-
-src_install() {
- dolib.so ${PN}.so*
- use static-libs && dolib.a ${PN}.a
- doheader unzip.h
-}
diff --git a/dev-libs/libunzip/metadata.xml b/dev-libs/libunzip/metadata.xml
deleted file mode 100644
index 097975e3a..000000000
--- a/dev-libs/libunzip/metadata.xml
+++ /dev/null
@@ -1,4 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-</pkgmetadata>