aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-23 12:47:09 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-23 12:47:09 +0100
commit504781317503147c49d3ea65de78b47e59993a59 (patch)
treebbc694cacb957fce2738ff232b4e3b5b9cf50d10 /dev-libs/optix
parentdev-python/sphinx-astropy: bump to version 1.7.0 (diff)
downloadsci-504781317503147c49d3ea65de78b47e59993a59.tar.gz
sci-504781317503147c49d3ea65de78b47e59993a59.tar.bz2
sci-504781317503147c49d3ea65de78b47e59993a59.zip
dev-libs/optix: add version 7.4.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-libs/optix')
-rw-r--r--dev-libs/optix/Manifest1
-rw-r--r--dev-libs/optix/optix-7.4.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/optix/Manifest b/dev-libs/optix/Manifest
index 11e08c79f..91d188077 100644
--- a/dev-libs/optix/Manifest
+++ b/dev-libs/optix/Manifest
@@ -2,3 +2,4 @@ DIST NVIDIA-OptiX-SDK-6.0.0-linux64-25650775.sh 642319364 BLAKE2B 5dc6e23d606ca9
DIST NVIDIA-OptiX-SDK-7.0.0-linux64.sh 28930132 BLAKE2B ae09bc862ccd39c25d5cc103d97b5587e21638079905e5811528b3d59deb7fd546034f24f73696c212274c0613f5b1dca7508bff696f5fec535dda7351166d7e SHA512 349baf367af7890afac87a879c8f7360cc9c93e984cf234216062af0a3cedce8fc6f3fd74240897d4b3854622ce1976a78433cbeadf6fa89c8e84d24e26eef89
DIST NVIDIA-OptiX-SDK-7.1.0-linux64-x86_64.sh 45564234 BLAKE2B 374bdbe5045ff36b71da8200ad29189cc3afba9783a38a74515caafeb90176eec5bf7a7d5e2045e47c399aa226a61fd12e6e7dd6c034b8a0f260a5850f775e47 SHA512 808a45e2007d8081de21fe15cad4577ba9fe10fc3612486b1230e03b7f17de91902dc773d1f3fef2b89398f230448d9522a03e19d4e6fa12aa4ffd78f1a4f9dc
DIST NVIDIA-OptiX-SDK-7.2.0-linux64-x86_64.sh 44573802 BLAKE2B 546f2f02336d7487e2aab3f348290aaf9bdac153a3fe161b48ad8a897f5d14f6126e06d3b8b4c301f8a6df5735d951dcf544795b2668bc42116bd909e032b18d SHA512 c37f36e2c0d5dbf151a03513e9dc82c21c46f1a88b123153647f44f4305367d1021e522236dda97ab9c641db006242507ae323d668cf2186cf04a83a54b5707f
+DIST NVIDIA-OptiX-SDK-7.4.0-linux64-x86_64.sh 57923655 BLAKE2B c3e159106ec6c8c446090ebd182fd3b0a75ec48b62e6984ae6559578688fd9a6cb29ea6065cb89aecdeb02247acbf3fb3bb0cbf69b10c29c222eb9fcbb0c6d90 SHA512 04f50c49d08c5e4e9be73ee322c4bff4f10a5e30445bc431e213c879a35cc5e36e0ceb8c864313f417628575a3c71593e65467ea13dd111b432fdf1db9383ae0
diff --git a/dev-libs/optix/optix-7.4.0.ebuild b/dev-libs/optix/optix-7.4.0.ebuild
new file mode 100644
index 000000000..a3f61205e
--- /dev/null
+++ b/dev-libs/optix/optix-7.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="NVIDIA Ray Tracing Engine"
+HOMEPAGE="https://developer.nvidia.com/optix"
+SRC_URI="NVIDIA-OptiX-SDK-${PV}-linux64-x86_64.sh"
+S="${WORKDIR}"
+
+SLOT="0/7"
+KEYWORDS="~amd64"
+RESTRICT="fetch mirror"
+LICENSE="NVIDIA-r2"
+
+RDEPEND="
+ dev-util/nvidia-cuda-toolkit:=
+ media-libs/freeglut
+ virtual/opengl
+"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your DISTDIR directory."
+ einfo 'DISTDIR value is available from `emerge --info`'
+}
+
+src_unpack() {
+ tail -n +223 "${DISTDIR}"/${A} | tar -zx || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ dodoc -r doc
+ doins -r include SDK
+}