aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2012-03-29 20:11:07 -0400
committerGuillaume Horel <guillaume.horel@gmail.com>2012-03-29 20:11:07 -0400
commit746048cf38c3ed125b92dc20e085218ec1021862 (patch)
tree3d257f63f7f5fc92d2ec7cd5bb732f3e9460f7a2 /dev-ml/lacaml/lacaml-6.0.4.ebuild
parentcorrect URI for icons (diff)
downloadsci-746048cf38c3ed125b92dc20e085218ec1021862.tar.gz
sci-746048cf38c3ed125b92dc20e085218ec1021862.tar.bz2
sci-746048cf38c3ed125b92dc20e085218ec1021862.zip
[dev-ml/lacaml] moved to new oasis eclass
Diffstat (limited to 'dev-ml/lacaml/lacaml-6.0.4.ebuild')
-rw-r--r--dev-ml/lacaml/lacaml-6.0.4.ebuild39
1 files changed, 16 insertions, 23 deletions
diff --git a/dev-ml/lacaml/lacaml-6.0.4.ebuild b/dev-ml/lacaml/lacaml-6.0.4.ebuild
index 00c7a9aa1..c0439cd33 100644
--- a/dev-ml/lacaml/lacaml-6.0.4.ebuild
+++ b/dev-ml/lacaml/lacaml-6.0.4.ebuild
@@ -4,7 +4,8 @@
EAPI=4
-inherit eutils findlib
+OASIS_BUILD_DOCS=1
+inherit oasis
DESCRIPTION="BLAS/LAPACK interface for OCaml"
HOMEPAGE="http://forge.ocamlcore.org/projects/lacaml"
@@ -13,28 +14,20 @@ SRC_URI="http://forge.ocamlcore.org/frs/download.php/806/${P}.tar.gz"
LICENSE="LGPL-2.1-linking-exception"
SLOT="0"
KEYWORDS="~x86"
-IUSE="doc"
+IUSE=""
-DEPEND="dev-lang/ocaml[ocamlopt]
- virtual/blas
+RDEPEND="virtual/blas
virtual/lapack"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- ocaml setup.ml -configure \
- --override conf_cclib "$(pkg-config --libs blas) \
-$(pkg-config --libs lapack)" \
- --destdir "${ED}" \
- --prefix "/usr" \
- --docdir "/usr/share/${PF}/doc" || die "configuration failed"
-}
-
-src_compile() {
- emake
- use doc && emake doc
-}
-
-src_install() {
- findlib_src_install
- dodoc README.txt Changelog
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( "README.txt" "Changelog" )
+
+src_prepare() {
+ cclib="$(pkg-config --libs blas lapack)"
+ cclib="[$(echo $cclib|sed -e 's/\(-[a-z0-9]*\) /\"\1\"\;/g' -e \
+ 's/\(-[a-z0-9]*\)$/\"\1\"/')]"
+ sed -i "s/cclib = \[\]/cclib = ${cclib}/" setup.conf
+ #would like to do the below, but doesn't work from ebuild
+ #oasis_configure_opts="--override conf_cclib $(pkg-config --libs blas atlas)
}