aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-09-16 10:13:39 -0600
committerChristoph Junghans <ottxor@gentoo.org>2014-09-16 10:13:39 -0600
commitc31c657089827988f8c0e373d4f324912796b59c (patch)
treee8c711a34e298c1cfd5c490643d12a2019d6b7ac /dev-ml/zarith/zarith-1.2.1.ebuild
parentremoved empty line (diff)
downloadsci-c31c657089827988f8c0e373d4f324912796b59c.tar.gz
sci-c31c657089827988f8c0e373d4f324912796b59c.tar.bz2
sci-c31c657089827988f8c0e373d4f324912796b59c.zip
clean up
Package-Manager: portage-2.2.8-r1
Diffstat (limited to 'dev-ml/zarith/zarith-1.2.1.ebuild')
-rw-r--r--dev-ml/zarith/zarith-1.2.1.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/dev-ml/zarith/zarith-1.2.1.ebuild b/dev-ml/zarith/zarith-1.2.1.ebuild
index 5657ff8c4..150070425 100644
--- a/dev-ml/zarith/zarith-1.2.1.ebuild
+++ b/dev-ml/zarith/zarith-1.2.1.ebuild
@@ -21,12 +21,12 @@ DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
RDEPEND="${DEPEND}"
pkg_setup() {
- OCAMLDIR=$(ocamlc -where)
+ OCAMLDIR=$(ocamlc -where)
}
src_prepare(){
- sed -e "s:(OCAMLFIND) install:(OCAMLFIND) install -ldconf \$(INSTALLDIR)/ld.conf:g" \
- -i ${S}/project.mak
+ sed -e 's:(OCAMLFIND) install:(OCAMLFIND) install -ldconf $(INSTALLDIR)/ld.conf:g' \
+ -i "${S}"/project.mak
}
src_configure(){
@@ -36,17 +36,15 @@ src_configure(){
}
src_compile(){
- emake || die "emake failed"
- if use doc; then
- emake doc || die "emake doc failed"
- fi
+ emake
+ use doc && emake doc
}
src_install(){
findlib_src_preinst
- cp ${OCAMLDIR}/ld.conf ${D}/${OCAMLDIR}/ld.conf
- emake install || die "emake install failed"
- rm -f ${D}/${OCAMLDIR}/ld.conf
+ cp "${OCAMLDIR}"/ld.conf "${D}/${OCAMLDIR}"/ld.conf
+ emake install
+ rm -f "${D}/${OCAMLDIR}"/ld.conf
dodoc Changes README
use doc && dodoc -r html/
}