aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorGuillaume Horel <guillaume.horel@gmail.com>2012-02-06 21:00:54 -0500
committerGuillaume Horel <guillaume.horel@gmail.com>2012-03-01 22:04:16 -0500
commit3f2908235115e7b91baf8a1be975e7843bf4c010 (patch)
tree5f2aa91adf1f75ffcd0f74e9d685c5193bb6ef89 /dev-ml
parentadded new petsc 3.2-p6 ebuild (diff)
downloadsci-3f2908235115e7b91baf8a1be975e7843bf4c010.tar.gz
sci-3f2908235115e7b91baf8a1be975e7843bf4c010.tar.bz2
sci-3f2908235115e7b91baf8a1be975e7843bf4c010.zip
[dev-ml/lacaml] version bump
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lacaml/ChangeLog8
-rw-r--r--dev-ml/lacaml/Manifest3
-rw-r--r--dev-ml/lacaml/lacaml-6.0.4.ebuild40
3 files changed, 49 insertions, 2 deletions
diff --git a/dev-ml/lacaml/ChangeLog b/dev-ml/lacaml/ChangeLog
index f771bb414..d3d8095d6 100644
--- a/dev-ml/lacaml/ChangeLog
+++ b/dev-ml/lacaml/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-ml/lacaml
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*lacaml-6.0.4 (02 Mar 2012)
+
+ 02 Mar 2012; Guillaume Horel <guillaume.horel@gmail.com>
+ +lacaml-6.0.4.ebuild:
+ version bump
+
*lacaml-5.5.2 (15 Nov 2011)
15 Nov 2011; Guillaume Horel <guillaume.horel@gmail.com>
diff --git a/dev-ml/lacaml/Manifest b/dev-ml/lacaml/Manifest
index 2637c4de3..7cff51881 100644
--- a/dev-ml/lacaml/Manifest
+++ b/dev-ml/lacaml/Manifest
@@ -1 +1,2 @@
-DIST lacaml-5.5.2.tar.bz2 91218 RMD160 a4b8bee49f38155fa176967a6d9ee5b864c0bd4b SHA1 274811e3a7f3a6772c5701a33ea707984a62fa04 SHA256 433a502f6ebb325e6965b63a267667549d1d0786dbf8f472c36f8df941074b29
+DIST lacaml-5.5.2.tar.bz2 91218 SHA256 433a502f6ebb325e6965b63a267667549d1d0786dbf8f472c36f8df941074b29 SHA512 b65c6e2755ce2c4a05f5010c59c26417e309f07cc4c0e019f33d80b24158e00a5cbbd9e5f7c4bd490e0b8160df4d3d4fcb7ab3b4f52541311ac020ed9e7881db WHIRLPOOL 387cda520a3e1c29ae6e13f88d83f7f63e717ebe0b8508f001c88847b3c4404a3baa5ab030753f5d1493666e8c5f85cd21137cf11f945873e9953948ff8888ee
+DIST lacaml-6.0.4.tar.gz 311807 SHA256 093e42deaf06bba2950c3a6b50c6b10ed215323f070bce3ea97b9577f278c7b6 SHA512 76d7915e8032afd860538cd59b3d5900a172482daef17c227213e19d5137acde6caec1ab83952b95b860d9b7821901b7b7b7f06ea044b4d0b71fbb7f970b18c6 WHIRLPOOL ceb57fc59624e4a418f055b461da47d68473bce8ca97897cbc6c0da220031ef6fff6fcb5027dabf01f44a797ceb25580a157eda92b6f0a85513f700bd870bead
diff --git a/dev-ml/lacaml/lacaml-6.0.4.ebuild b/dev-ml/lacaml/lacaml-6.0.4.ebuild
new file mode 100644
index 000000000..00c7a9aa1
--- /dev/null
+++ b/dev-ml/lacaml/lacaml-6.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils findlib
+
+DESCRIPTION="BLAS/LAPACK interface for OCaml"
+HOMEPAGE="http://forge.ocamlcore.org/projects/lacaml"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/806/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/ocaml[ocamlopt]
+ virtual/blas
+ virtual/lapack"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ocaml setup.ml -configure \
+ --override conf_cclib "$(pkg-config --libs blas) \
+$(pkg-config --libs lapack)" \
+ --destdir "${ED}" \
+ --prefix "/usr" \
+ --docdir "/usr/share/${PF}/doc" || die "configuration failed"
+}
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.txt Changelog
+}