aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-14 22:11:06 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-14 22:11:06 +0100
commit33d826f1d4c632c23afeb7da07d887e4ad672e34 (patch)
treedb55cc6f213e46de07557cfcf6d45e0b5d43f8aa /dev-python/asdf
parentsci-libs/superlu_dist: use https (diff)
downloadsci-33d826f1d4c632c23afeb7da07d887e4ad672e34.tar.gz
sci-33d826f1d4c632c23afeb7da07d887e4ad672e34.tar.bz2
sci-33d826f1d4c632c23afeb7da07d887e4ad672e34.zip
dev-python/asdf: new dep of specutils
Thanks to @malfatti Closes: https://github.com/gentoo/sci/pull/964 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/asdf')
-rw-r--r--dev-python/asdf/Manifest1
-rw-r--r--dev-python/asdf/asdf-2.7.1.ebuild44
-rw-r--r--dev-python/asdf/metadata.xml8
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/asdf/Manifest b/dev-python/asdf/Manifest
new file mode 100644
index 000000000..ed535128d
--- /dev/null
+++ b/dev-python/asdf/Manifest
@@ -0,0 +1 @@
+DIST asdf-2.7.1.tar.gz 494491 BLAKE2B 7ff36829626972e85362cb364bdf5ced4745a592c7229b70584ef36722935959a21c6cc11a37ea58c625c1aefdee96d72d5edfef67e5a7975c653f70ed9689c1 SHA512 dc807013d7dbf67c8cb269398d0b7ff56b1c5212d2cfbb768b7844979951c56b9263327cba3a3db32b65ac9de2ede94731823b4d7f120a4306efc203cfc75266
diff --git a/dev-python/asdf/asdf-2.7.1.ebuild b/dev-python/asdf/asdf-2.7.1.ebuild
new file mode 100644
index 000000000..ddace4966
--- /dev/null
+++ b/dev-python/asdf/asdf-2.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for the Advanced Scientific Data Format"
+HOMEPAGE="https://asdf.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/pytest-doctestplus[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/gwcs[${PYTHON_USEDEP}]
+ )
+ doc? ( media-gfx/graphviz )
+"
+
+RDEPEND="
+ >=dev-python/jsonschema-3.0.2[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/semantic_version-2.8[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/astropy dev-python/sphinx-astropy dev-python/matplotlib dev-python/docutils
+
+python_test() {
+ # discovers things in docs dir if we do not
+ # explicitly set it to run on the tests dir
+ pytest -vv asdf/tests || die " Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/asdf/metadata.xml b/dev-python/asdf/metadata.xml
new file mode 100644
index 000000000..4f4367037
--- /dev/null
+++ b/dev-python/asdf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+</pkgmetadata>