aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-20 19:54:41 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-10-20 19:54:52 +0000
commit484fcdf3fbd53f2a0a7211136d3e803eb0249706 (patch)
treedc836fac52be7bad79a65c9807570cd3bd1ad1c2 /dev-python/bokeh
parentdev-python/PyVISA: PYTHON_COMPAT, dep, and test updates (diff)
downloadsci-484fcdf3fbd53f2a0a7211136d3e803eb0249706.tar.gz
sci-484fcdf3fbd53f2a0a7211136d3e803eb0249706.tar.bz2
sci-484fcdf3fbd53f2a0a7211136d3e803eb0249706.zip
dev-python/bokeh: add python3.8
fix eutils -> optfeature Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python/bokeh')
-rw-r--r--dev-python/bokeh/bokeh-2.2.1-r1.ebuild (renamed from dev-python/bokeh/bokeh-2.2.2.ebuild)11
-rw-r--r--dev-python/bokeh/bokeh-2.2.2-r1.ebuild (renamed from dev-python/bokeh/bokeh-2.2.1.ebuild)14
2 files changed, 10 insertions, 15 deletions
diff --git a/dev-python/bokeh/bokeh-2.2.2.ebuild b/dev-python/bokeh/bokeh-2.2.1-r1.ebuild
index 20e2788a5..206e6962e 100644
--- a/dev-python/bokeh/bokeh-2.2.2.ebuild
+++ b/dev-python/bokeh/bokeh-2.2.1-r1.ebuild
@@ -3,12 +3,11 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
# upstream hasn't tested python 3.8 fully
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 eutils
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1 optfeature
DESCRIPTION="Statistical and interactive HTML plots for Python"
HOMEPAGE="https://bokeh.org/
@@ -20,8 +19,6 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DISTUTILS_IN_SOURCE_BUILD=1
-
# upstream authoritative dependencies
# https://github.com/bokeh/bokeh/blob/master/conda.recipe/meta.yaml
RDEPEND="
diff --git a/dev-python/bokeh/bokeh-2.2.1.ebuild b/dev-python/bokeh/bokeh-2.2.2-r1.ebuild
index b7b594273..206e6962e 100644
--- a/dev-python/bokeh/bokeh-2.2.1.ebuild
+++ b/dev-python/bokeh/bokeh-2.2.2-r1.ebuild
@@ -3,12 +3,11 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
# upstream hasn't tested python 3.8 fully
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 eutils
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1 optfeature
DESCRIPTION="Statistical and interactive HTML plots for Python"
HOMEPAGE="https://bokeh.org/
@@ -20,8 +19,6 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DISTUTILS_IN_SOURCE_BUILD=1
-
# upstream authoritative dependencies
# https://github.com/bokeh/bokeh/blob/master/conda.recipe/meta.yaml
RDEPEND="
@@ -46,6 +43,7 @@ BDEPEND="
dev-python/networkx[${PYTHON_USEDEP}]
dev-python/nbconvert[${PYTHON_USEDEP}]
dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/selenium[${PYTHON_USEDEP}]
@@ -55,7 +53,7 @@ BDEPEND="
distutils_enable_tests pytest
PATCHES=(
- "${FILESDIR}"/${P}-conftest_py.patch
+ "${FILESDIR}"/${PN}-2.2.1-conftest_py.patch
)
python_test() {