aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-01-23 18:38:45 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-01-23 18:38:45 +0100
commit772923c6077f36d7ecf079be06b9a8c72c1bf915 (patch)
treedb05e68ab43466fbbce281e3437674fa70488587 /dev-python/bokeh
parentdev-python/bokeh: Fix bumped ebuild (diff)
downloadsci-772923c6077f36d7ecf079be06b9a8c72c1bf915.tar.gz
sci-772923c6077f36d7ecf079be06b9a8c72c1bf915.tar.bz2
sci-772923c6077f36d7ecf079be06b9a8c72c1bf915.zip
dev-python/bokeh: Replace pkg_postinst by readme.gentoo
Diffstat (limited to 'dev-python/bokeh')
-rw-r--r--dev-python/bokeh/bokeh-0.7.1.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/dev-python/bokeh/bokeh-0.7.1.ebuild b/dev-python/bokeh/bokeh-0.7.1.ebuild
index 88d4e69a7..63072d38c 100644
--- a/dev-python/bokeh/bokeh-0.7.1.ebuild
+++ b/dev-python/bokeh/bokeh-0.7.1.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1
+inherit distutils-r1 readme.gentoo
DESCRIPTION="Statistical and interactive HTML plots for Python"
HOMEPAGE="http://bokeh.pydata.org/"
@@ -59,6 +59,8 @@ PATCHES=( "${FILESDIR}"/${P}-setup.patch )
DISTUTILS_NO_PARALLEL_BUILD=1
python_prepare_all() {
+ DOC_CONTENTS="websockets work only with python2_7"
+
sed -i -e "s/jsbuild = get_user_jsargs()/jsbuild = False/g" setup.py || die
cd bokehjs || die
npm install ||die
@@ -69,6 +71,8 @@ python_prepare_all() {
}
python_install_all() {
+ readme.gentoo_create_doc
+
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
@@ -82,15 +86,3 @@ python_test() {
-e usermodel_test \
|| die
}
-
-pkg_postinst() {
- elog "websockets work only with python2_7"
- local chaco_msg="chaco useflag doesn't affect python targets other than python2_7"
- if use chaco; then
- if use python_targets_python2_7; then
- elog "${chaco_msg}"
- else
- ewarn "${chaco_msg}"
- fi
- fi
-}