aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-02-25 01:08:28 +0000
committerAisha Tammy <gentoo@aisha.cc>2021-02-25 01:09:50 +0000
commit9594eb89b6774efda3c317336d09aa4991542eab (patch)
treecefd3475fc974d4ebfb1e64129f695e7670c40bc /dev-python/bokeh
parentapp-offic/visidata: use distutils_enable_tests (diff)
downloadsci-9594eb89b6774efda3c317336d09aa4991542eab.tar.gz
sci-9594eb89b6774efda3c317336d09aa4991542eab.tar.bz2
sci-9594eb89b6774efda3c317336d09aa4991542eab.zip
dev-python/bokeh: version bump to 2.3.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-python/bokeh')
-rw-r--r--dev-python/bokeh/Manifest2
-rw-r--r--dev-python/bokeh/bokeh-2.3.0.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/bokeh/Manifest b/dev-python/bokeh/Manifest
index 93cc6a37e..ce4acf83a 100644
--- a/dev-python/bokeh/Manifest
+++ b/dev-python/bokeh/Manifest
@@ -1,3 +1,5 @@
DIST bokeh-2.2.1.tar.gz 8845855 BLAKE2B 54846c4033a57677a197ee736266993401e00da791b0b2202e2d1683cb044d26f0ab958340f3ed2603bc78100e30b09aa7e569fff26eb235ebcb53beb7720b3a SHA512 8f58196468750f8fa24b4a8165ecb1407e61cfe207f1e0c82f0efc83d7b41f1db73ae56363e52bccc3b1f1cb9cc93f1a3ab40af0bb4b981e8b241c4c19c7b900
DIST bokeh-2.2.2.tar.gz 8847568 BLAKE2B b279e72106ec7771fbdad6709d529e5b5e23152eae6feeae2b5cddceeba1d9db5def6c1f99cb884739536b2ecbe33060531a229f8838bcf4fa69aadf42053619 SHA512 5a53a11e3252dd904c5a436733f520251b7990bf2f112315cd5c76f0d26a6733888a36f73954c3339647981971400fc815710a3a9a753db4c9cdf10c5e2a1643
DIST bokeh-2.2.3.tar.gz 8848373 BLAKE2B 4bae1e729980bced589c256213df22cabc08b8105113698b0e5eefd37760506a625212931dcafb8c00f1a2fce1b77a48b4802ede4a3f09c73f09b8dbe39a1a81 SHA512 7d7cf6b4207644894c8a358e235f2901f65b453f3324c1b766ddca67b287e13e82df67c193ba87123d5b3b855f7ba29c01e2113fb787dd60c39bef6ba7c95aba
+DIST bokeh-2.3.0.tar.gz 10617724 BLAKE2B ee20260b17a9d2fd13df0dab92d317b0c3a1709945e85bd0697f66d9d4363422fbb3efc29f0b402d5c8f7fab1e2f9d6903bc4da7951af88a7cf101ae85c1a535 SHA512 9e584810ffd1cc66b2c97ffbd527cb0fe4a7c63dd0cc9ddae29beae167db9c4333c2323928a91117ac226e401997dd2b2d6f8968c0618c3b40c70c6bac334c95
+DIST conftest-bokeh-2.3.0.py 1749 BLAKE2B 60b24d84e606d06c6913ddd6cac0ddf5aecc9989b3d87c896ef554da30968e9762224e32d63cc6f5c405a279608c92153e182e4e611bd635f5d307618597469c SHA512 e352b34da8156fd9764c483a01e3979f6e44c82163cd40fef471382f23566f824e09d3ef579e7d279a546e58fc26fa169afdd6ba74a21ab79c71bb173a1c5a5b
diff --git a/dev-python/bokeh/bokeh-2.3.0.ebuild b/dev-python/bokeh/bokeh-2.3.0.ebuild
new file mode 100644
index 000000000..c3f35c24c
--- /dev/null
+++ b/dev-python/bokeh/bokeh-2.3.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Statistical and interactive HTML plots for Python"
+HOMEPAGE="https://bokeh.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ https://raw.githubusercontent.com/bokeh/bokeh/${PV}/conftest.py -> conftest-${P}.py
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# upstream authoritative dependencies
+# https://github.com/bokeh/bokeh/blob/master/conda.recipe/meta.yaml
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all(){
+ cp "${DISTDIR}"/conftest-${P}.py "${S}"/conftest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # disable tests having network calls
+ local SKIP_TESTS=" \
+ not (test___init__ and TestWarnings and test_filters) and \
+ not (test_json__subcommands and test_no_script) and \
+ not (test_standalone and Test_autoload_static) and \
+ not test_nodejs_compile_javascript and \
+ not test_nodejs_compile_less and \
+ not test_inline_extension and \
+ not (test_model and test_select) and \
+ not test_tornado__server and \
+ not test_client_server and \
+ not test_webdriver and \
+ not test_export and \
+ not test_server and \
+ not test_bundle and \
+ not test_ext \
+ "
+ pytest -m "not sampledata" tests/unit -k \
+ "${SKIP_TESTS}" -vv || die "unittests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "integration with amazon S3" dev-python/boto
+ optfeature "pypi integration to publish packages" dev-python/twine
+ optfeature "js library usage" net-libs/nodejs
+}