aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-14 08:35:31 -0500
committerHorea Christian <chr@chymera.eu>2023-01-14 08:35:31 -0500
commite2b40b3e66efe795828adb65937da626386382ce (patch)
tree3e43a2125ae3b9734fba9f3a23e9b9ffea67f86e /dev-python/colorcet/colorcet-3.0.1.ebuild
parentdev-python/colorcet: update EAPI and PYTHON_COMPAT (diff)
downloadsci-e2b40b3e66efe795828adb65937da626386382ce.tar.gz
sci-e2b40b3e66efe795828adb65937da626386382ce.tar.bz2
sci-e2b40b3e66efe795828adb65937da626386382ce.zip
dev-python/colorcet: add 3.0.1
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/colorcet/colorcet-3.0.1.ebuild')
-rw-r--r--dev-python/colorcet/colorcet-3.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/colorcet/colorcet-3.0.1.ebuild b/dev-python/colorcet/colorcet-3.0.1.ebuild
new file mode 100644
index 000000000..d47f5d2a4
--- /dev/null
+++ b/dev-python/colorcet/colorcet-3.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Portage incorrectly claims "DISTUTILS_USE_SETUPTOOLS value is probably
+# incorrect" for this package. It isn't. This package imports from neither
+# "distutils", "packaging", "pkg_resources", nor "setuptools" at runtime.
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of perceptually uniform colormaps"
+HOMEPAGE="https://holoviz.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/param-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyct-0.4.4[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest