aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-13 15:22:06 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-13 15:22:06 +0200
commit63242ac9625ad8745861738c71a2159868f276ca (patch)
tree1a6bf52113184ed72c34d6f1caf14133082b6be8 /dev-python/coords/coords-0.37.ebuild
parentdev-python/ffc: Version Bump; Bump to EAPI=5 and distutils-r1.eclass (diff)
downloadsci-63242ac9625ad8745861738c71a2159868f276ca.tar.gz
sci-63242ac9625ad8745861738c71a2159868f276ca.tar.bz2
sci-63242ac9625ad8745861738c71a2159868f276ca.zip
dev-python/coords: Bump to EAPI=5 and distutils-r1.eclass
Package-Manager: portage-2.2.0_alpha179
Diffstat (limited to 'dev-python/coords/coords-0.37.ebuild')
-rw-r--r--dev-python/coords/coords-0.37.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/dev-python/coords/coords-0.37.ebuild b/dev-python/coords/coords-0.37.ebuild
index c9be8c7c8..6cad605f0 100644
--- a/dev-python/coords/coords-0.37.ebuild
+++ b/dev-python/coords/coords-0.37.ebuild
@@ -1,17 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit distutils
+inherit distutils-r1
DESCRIPTION="Managing astronomical coordinate systems"
-HOMEPAGE="https://trac6.assembla.com/astrolib/wiki/ http://www.scipy.org/AstroLib/"
+HOMEPAGE="https://trac6.assembla.com/astrolib/wiki/"
SRC_URI="http://stsdas.stsci.edu/astrolib/${P}.tar.gz"
LICENSE="AURA"
@@ -20,12 +18,8 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
-RDEPEND="dev-python/numpy"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-src_test() {
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" -c "import coords as C; print C._test()"
- }
- # FIX ME: test fail on amd64, reported upstream
- use amd64 || python_execute_function testing
+python_test() {
+ "${PYTHON}" -c "import coords as C; print C._test()" || die
}