aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-05-02 03:21:32 -0400
committerHorea Christian <chr@chymera.eu>2022-05-02 03:21:32 -0400
commitb3861c4b774b14f9017367bbc474d8890999dbf8 (patch)
tree5dba8b5ab068f70bf12c8a6c5bf1b19ec7cb14b0 /dev-python/dandi-schema
parentdev-python/fscacher: upstream inplace source archive update (diff)
downloadsci-b3861c4b774b14f9017367bbc474d8890999dbf8.tar.gz
sci-b3861c4b774b14f9017367bbc474d8890999dbf8.tar.bz2
sci-b3861c4b774b14f9017367bbc474d8890999dbf8.zip
dev-python/dandi-schema: new package
will deprecate dev-python/dandischema Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/dandi-schema')
-rw-r--r--dev-python/dandi-schema/Manifest4
-rw-r--r--dev-python/dandi-schema/dandi-schema-0.4.3.ebuild46
-rw-r--r--dev-python/dandi-schema/dandi-schema-0.5.1.ebuild42
-rw-r--r--dev-python/dandi-schema/dandi-schema-0.5.3.ebuild42
-rw-r--r--dev-python/dandi-schema/dandi-schema-0.6.0.ebuild42
-rw-r--r--dev-python/dandi-schema/files/dandi-schema-0.3.4-coverage.patch11
-rw-r--r--dev-python/dandi-schema/files/dandi-schema-0.3.4-versioningit.patch10
-rw-r--r--dev-python/dandi-schema/metadata.xml26
8 files changed, 223 insertions, 0 deletions
diff --git a/dev-python/dandi-schema/Manifest b/dev-python/dandi-schema/Manifest
new file mode 100644
index 000000000..cb098f9b4
--- /dev/null
+++ b/dev-python/dandi-schema/Manifest
@@ -0,0 +1,4 @@
+DIST dandi-schema-0.4.3.tar.gz 51831 BLAKE2B 177a0ec148c1e823abdaa2b7e60d971c17a7f49bc72b69b16989e32ed014cf6df6378530be7fa142ca49662134a169b21903e9c49d9849ee944dfa9462fe6c3a SHA512 3d6c8f8cf86c933a04017f34a3832d642cf4ee27fd3edf6cf57ceab2e0ad6a1b82c245e4e27283913db941f86877996256604d345c1ee798acca2981ee046b5e
+DIST dandi-schema-0.5.1.tar.gz 55945 BLAKE2B b9af1b34c7e4ce07b2fdac1d74dd746684f9e5e4667890931bbf2cb2421a01690eaed5114f2d077c46304f1298475739acef5a256430cac470ceb9fc1884e182 SHA512 699e9fb6626dd87576f29b908cd259748a6ebbd94391d8c5ba821273496323a3b4b9e88ee337809abc65c9aaeadca8aee4d986c173b055914c4ca67ddfd88804
+DIST dandi-schema-0.5.3.tar.gz 56222 BLAKE2B 3b23c93330f621a5a050c9e5b597fd8b9046a66465c16f26b5216d443547a0c8d07a491213cde90c411f5cda6f6c6b2a23d1c0f4b2d7a1e7336c55e5768d3338 SHA512 bf0d434ac6d8e5584ba9f31dd179e5402c13c89257bc87c2d34b03483e9ab85d9b616391a40c64ad853e6774f950ecc58d3f3fde29305586d5faa387dc5b3e80
+DIST dandi-schema-0.6.0.tar.gz 57102 BLAKE2B eb4ef024ef87e234c4c9e741fa2e70920aa13e0ab661aa179553b81ae8d28853274102b49532fc542368ebb43be9779a96434134e35b7c3380609511bed5ce8c SHA512 e2846e3e573264b83e95d92e7d2f2e4177721f32228beb63c701280312611bc668d1042248f4c65ed8f07b8c80991c398a4d29969513f235b4d37369cae0ddcd
diff --git a/dev-python/dandi-schema/dandi-schema-0.4.3.ebuild b/dev-python/dandi-schema/dandi-schema-0.4.3.ebuild
new file mode 100644
index 000000000..cf3c8a34f
--- /dev/null
+++ b/dev-python/dandi-schema/dandi-schema-0.4.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Schemata for DANDI archive project"
+HOMEPAGE="https://github.com/dandi/dandi-schema"
+SRC_URI="https://github.com/dandi/dandi-schema/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/python-email-validator[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.4-coverage.patch"
+ "${FILESDIR}/${PN}-0.3.4-versioningit.patch"
+)
+
+src_configure() {
+ echo "__version__ = '${PV}'" >> dandischema/_version.py
+}
+
+distutils_enable_tests pytest
+
+python_test() {
+ export DANDI_TESTS_NONETWORK=1
+ pushd dandischema || die
+ epytest tests
+ popd
+}
diff --git a/dev-python/dandi-schema/dandi-schema-0.5.1.ebuild b/dev-python/dandi-schema/dandi-schema-0.5.1.ebuild
new file mode 100644
index 000000000..19a906634
--- /dev/null
+++ b/dev-python/dandi-schema/dandi-schema-0.5.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Schemata for DANDI archive project"
+HOMEPAGE="https://github.com/dandi/dandi-schema"
+SRC_URI="https://github.com/dandi/dandi-schema/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/python-email-validator[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.4-coverage.patch"
+)
+
+src_configure() {
+ echo "__version__ = '${PV}'" >> dandischema/_version.py
+}
+
+distutils_enable_tests pytest
+
+python_test() {
+ export DANDI_TESTS_NONETWORK=1
+ pushd dandischema || die
+ epytest tests
+ popd
+}
diff --git a/dev-python/dandi-schema/dandi-schema-0.5.3.ebuild b/dev-python/dandi-schema/dandi-schema-0.5.3.ebuild
new file mode 100644
index 000000000..19a906634
--- /dev/null
+++ b/dev-python/dandi-schema/dandi-schema-0.5.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Schemata for DANDI archive project"
+HOMEPAGE="https://github.com/dandi/dandi-schema"
+SRC_URI="https://github.com/dandi/dandi-schema/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/python-email-validator[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.4-coverage.patch"
+)
+
+src_configure() {
+ echo "__version__ = '${PV}'" >> dandischema/_version.py
+}
+
+distutils_enable_tests pytest
+
+python_test() {
+ export DANDI_TESTS_NONETWORK=1
+ pushd dandischema || die
+ epytest tests
+ popd
+}
diff --git a/dev-python/dandi-schema/dandi-schema-0.6.0.ebuild b/dev-python/dandi-schema/dandi-schema-0.6.0.ebuild
new file mode 100644
index 000000000..19a906634
--- /dev/null
+++ b/dev-python/dandi-schema/dandi-schema-0.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Schemata for DANDI archive project"
+HOMEPAGE="https://github.com/dandi/dandi-schema"
+SRC_URI="https://github.com/dandi/dandi-schema/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/python-email-validator[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.4-coverage.patch"
+)
+
+src_configure() {
+ echo "__version__ = '${PV}'" >> dandischema/_version.py
+}
+
+distutils_enable_tests pytest
+
+python_test() {
+ export DANDI_TESTS_NONETWORK=1
+ pushd dandischema || die
+ epytest tests
+ popd
+}
diff --git a/dev-python/dandi-schema/files/dandi-schema-0.3.4-coverage.patch b/dev-python/dandi-schema/files/dandi-schema-0.3.4-coverage.patch
new file mode 100644
index 000000000..a9c7b6c2b
--- /dev/null
+++ b/dev-python/dandi-schema/files/dandi-schema-0.3.4-coverage.patch
@@ -0,0 +1,11 @@
+--- a/tox.ini 2021-09-22 19:31:20.534576095 -0400
++++ b/tox.ini 2021-09-26 16:11:30.080164191 -0400
+@@ -17,7 +17,7 @@
+ flake8 --config=setup.cfg {posargs} dandischema setup.py
+
+ [pytest]
+-addopts = --cov=dandischema --tb=short --durations=10
++addopts = --tb=short --durations=10
+ filterwarnings = error
+
+ [coverage:run]
diff --git a/dev-python/dandi-schema/files/dandi-schema-0.3.4-versioningit.patch b/dev-python/dandi-schema/files/dandi-schema-0.3.4-versioningit.patch
new file mode 100644
index 000000000..589091756
--- /dev/null
+++ b/dev-python/dandi-schema/files/dandi-schema-0.3.4-versioningit.patch
@@ -0,0 +1,10 @@
+--- a/setup.py 2021-09-22 19:31:20.533576086 -0400
++++ b/setup.py 2021-09-23 07:42:02.856983656 -0400
+@@ -21,7 +21,7 @@
+
+ # Give setuptools a hint to complain if it's too old a version
+ # Should match pyproject.toml
+-SETUP_REQUIRES = ["setuptools >= 42.0.0", "versioningit ~= 0.1.0"]
++SETUP_REQUIRES = ["setuptools >= 42.0.0"]
+ # This enables setuptools to install wheel on-the-fly
+ SETUP_REQUIRES += ["wheel"] if "bdist_wheel" in sys.argv else []
diff --git a/dev-python/dandi-schema/metadata.xml b/dev-python/dandi-schema/metadata.xml
new file mode 100644
index 000000000..91cb893fc
--- /dev/null
+++ b/dev-python/dandi-schema/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Python library for maintaining and managing DANDI metadata schemata.
+ The library helps create and validate DANDI schema-compliant metadata
+ for Dandisets and assets. Every Dandiset and associated asset has a
+ metadata object that can be retrieved using the DANDI API. This
+ library uses Pydantic to implement all the metadata classes. Schemas
+ are generated on schema modifications and placed into this repository.
+ Dandischema generates JSON schema definitions and also an associated
+ context.json file for JSON-LD compliance of the metadata models.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">dandi/dandi-schema</remote-id>
+ <remote-id type="pypi">dandischema</remote-id>
+ </upstream>
+</pkgmetadata>