aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-02 13:26:59 +0100
committerHorea Christian <chr@chymera.eu>2021-01-02 23:30:12 -0500
commit574fc6b172a1c4afd0fc849e998283050e7f371d (patch)
treee07248004841c0bf0a5cff735a55e6fa21c0a46b /dev-python/dijitso
parentdev-python/bcbio-gff: version bump, bump py targets (diff)
downloadsci-574fc6b172a1c4afd0fc849e998283050e7f371d.tar.gz
sci-574fc6b172a1c4afd0fc849e998283050e7f371d.tar.bz2
sci-574fc6b172a1c4afd0fc849e998283050e7f371d.zip
dev-python/dijitso: bump python targets, enbale tests
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/dijitso')
-rw-r--r--dev-python/dijitso/Manifest1
-rw-r--r--dev-python/dijitso/dijitso-2016.2.0.ebuild19
-rw-r--r--dev-python/dijitso/dijitso-2017.1.0.ebuild17
3 files changed, 12 insertions, 25 deletions
diff --git a/dev-python/dijitso/Manifest b/dev-python/dijitso/Manifest
index 51877e8e3..d822cce7e 100644
--- a/dev-python/dijitso/Manifest
+++ b/dev-python/dijitso/Manifest
@@ -1,2 +1 @@
-DIST dijitso-2016.2.0.tar.gz 50947 BLAKE2B 7f7a8feff5f3331601707deca74d313e756b8c8481c64dd41f3f765ed3fc311addb6f1b59eff5cd1eab35b1633604ced321b7defea26101875be6cc34d086c93 SHA512 adae206e2c484db9b373bcf67f974147e3e9196ec4af12cd02cf1698eff3eeb0b1b67ad36383e3588b025844e0437f0f03b701a5c83178f40ee5817f0b47b24a
DIST dijitso-2017.1.0.tar.gz 51223 BLAKE2B dd36d97ae3051779a4a21f277fddd02460f3572029b70a1fa5a799a54749cbd807bf9e12a41f2138cc917dfa3ea43368a96bb079dc2e99b6be6900f735e425ce SHA512 994c3d88ca207b3d3065f9376546580492a06eda51a340fc16bbd768248dc26a2984af064e9d970657509b003e403db329aea9ca9cca2f428764b7ec0a367040
diff --git a/dev-python/dijitso/dijitso-2016.2.0.ebuild b/dev-python/dijitso/dijitso-2016.2.0.ebuild
deleted file mode 100644
index fb0bc43bd..000000000
--- a/dev-python/dijitso/dijitso-2016.2.0.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for distributed just-in-time shared library building"
-HOMEPAGE="https://bitbucket.org/fenics-project/dijitso/"
-SRC_URI="https://bitbucket.org/fenics-project/dijitso/downloads/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-python/mpi4py"
diff --git a/dev-python/dijitso/dijitso-2017.1.0.ebuild b/dev-python/dijitso/dijitso-2017.1.0.ebuild
index cea6e39ff..cef1e1eb7 100644
--- a/dev-python/dijitso/dijitso-2017.1.0.ebuild
+++ b/dev-python/dijitso/dijitso-2017.1.0.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -14,6 +15,12 @@ SRC_URI="https://bitbucket.org/fenics-project/dijitso/downloads/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="dev-python/mpi4py"
+RDEPEND="
+ dev-python/mpi4py[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# TODO: fix this, seems to require self
+#distutils_enable_sphinx doc/sphinx/source
+distutils_enable_tests --install pytest