aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bettler <thomas.bettler@gmail.com>2022-01-16 12:00:42 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-18 17:37:50 +0100
commita7d5d4c5796ec77b9f6b40726aeee5a0245af2d1 (patch)
tree66fa56b6be8d80d0d7dc1ee0f6be2412898a478b /dev-python/geopandas/geopandas-0.10.2.ebuild
parentdev-python/fiona: new 1.8.20 (diff)
downloadsci-a7d5d4c5796ec77b9f6b40726aeee5a0245af2d1.tar.gz
sci-a7d5d4c5796ec77b9f6b40726aeee5a0245af2d1.tar.bz2
sci-a7d5d4c5796ec77b9f6b40726aeee5a0245af2d1.zip
dev-python/geopandas: new 0.10.2
new pkg for geodata engineering status: test pass, works for me Signed-off-by: Thomas Bettler <thomas.bettler@gmail.com> Closes: https://github.com/gentoo/sci/pull/1138 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/geopandas/geopandas-0.10.2.ebuild')
-rw-r--r--dev-python/geopandas/geopandas-0.10.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/geopandas/geopandas-0.10.2.ebuild b/dev-python/geopandas/geopandas-0.10.2.ebuild
new file mode 100644
index 000000000..6dde1c23f
--- /dev/null
+++ b/dev-python/geopandas/geopandas-0.10.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517="setuptools"
+inherit distutils-r1
+
+DESCRIPTION="Python tools for geographic data"
+HOMEPAGE="https://github.com/geopandas/geopandas"
+SRC_URI="https://github.com/geopandas/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pandas[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ dev-python/fiona[${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # disable tests due to networking being blocked
+ geopandas/io/tests/test_file.py::test_read_file_remote_zipfile_url
+ geopandas/io/tests/test_file.py::test_read_file_remote_geojson_url
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}