aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2021-10-16 03:02:57 -0400
committerHorea Christian <chr@chymera.eu>2021-10-16 03:02:57 -0400
commit36441dccfc78d0c85f87373d9573f4b66ce491c9 (patch)
tree54b0539ad765c45a8b597ffed67582e831b7125f /dev-python/keyrings_alt
parentdev-python/annexremote: new package (diff)
downloadsci-36441dccfc78d0c85f87373d9573f4b66ce491c9.tar.gz
sci-36441dccfc78d0c85f87373d9573f4b66ce491c9.tar.bz2
sci-36441dccfc78d0c85f87373d9573f4b66ce491c9.zip
dev-python/keyrings_alt: new package
DataLad stack Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python/keyrings_alt')
-rw-r--r--dev-python/keyrings_alt/Manifest1
-rw-r--r--dev-python/keyrings_alt/keyrings_alt-4.1.0.ebuild25
-rw-r--r--dev-python/keyrings_alt/metadata.xml24
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/keyrings_alt/Manifest b/dev-python/keyrings_alt/Manifest
new file mode 100644
index 000000000..ec1eff845
--- /dev/null
+++ b/dev-python/keyrings_alt/Manifest
@@ -0,0 +1 @@
+DIST keyrings.alt-4.1.0.tar.gz 28581 BLAKE2B bb4c8c5faa130c4cfb377985ee8692bcce802f0e03d1121281a8d73ac1c4ced4c6f913e6ab9ff39b1b7d37ff41b37905910d3a02e91fa4160fbe109aa16c2ae0 SHA512 6c2a7637bc73971081b95851898dcc2fafe5fd155333cee7032983b16f668d8db941c972747c7c4a2e20b4d6a5fe52d8ad96448f8ae7d372cd1c32e2a0d344f9
diff --git a/dev-python/keyrings_alt/keyrings_alt-4.1.0.ebuild b/dev-python/keyrings_alt/keyrings_alt-4.1.0.ebuild
new file mode 100644
index 000000000..247679bb6
--- /dev/null
+++ b/dev-python/keyrings_alt/keyrings_alt-4.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="keyrings.alt"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Alternate keyring backend implementations used with dev-python/keyring"
+HOMEPAGE="https://github.com/jaraco/keyrings.alt/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~x86"
+
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
diff --git a/dev-python/keyrings_alt/metadata.xml b/dev-python/keyrings_alt/metadata.xml
new file mode 100644
index 000000000..59728c331
--- /dev/null
+++ b/dev-python/keyrings_alt/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package distributes backends extracted from the main Python keyring
+ project to make them available for those who wish to employ them, but
+ are discouraged for general production use. Include this module and use
+ its backends at your own risk.
+ For example, the PlaintextKeyring stores passwords in plain text on the
+ file system, defeating the intended purpose of this library to encourage
+ best practices for security.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jaraco/keyrings.alt</remote-id>
+ </upstream>
+</pkgmetadata>